gnu: retroarch: Update to 1.15.0.

* gnu/packages/emulators.scm (retroarch): Update to 1.15.0.
[source]: Remove upstreamed patch.
[arguments]<#:phases>: Remove not needed changes for 'true' and 'zlib'.
Remove "--disable-builtinminiupnpc" from configure flags.
Add "--disable-builtinzlib" to configure flags.
[inputs]: Remove miniupnpc, which is not used any more.
* gnu/packages/patches/retroarch-LIBRETRO_DIRECTORY: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
宋文武 2023-03-11 21:21:26 +08:00
parent 3893758dac
commit 5dd0a6214f
No known key found for this signature in database
GPG Key ID: D415BF253B515976
3 changed files with 3 additions and 50 deletions

View File

@ -1805,7 +1805,6 @@ dist_patch_DATA = \
%D%/packages/patches/racket-zuo-bin-sh.patch \
%D%/packages/patches/remake-impure-dirs.patch \
%D%/packages/patches/restic-0.9.6-fix-tests-for-go1.15.patch \
%D%/packages/patches/retroarch-LIBRETRO_DIRECTORY.patch \
%D%/packages/patches/r-mixedpower-r2power.patch \
%D%/packages/patches/rng-tools-revert-build-randstat.patch \
%D%/packages/patches/rocm-comgr-3.1.0-dependencies.patch \

View File

@ -1420,7 +1420,7 @@ as RetroArch.")
(define-public retroarch
(package
(name "retroarch")
(version "1.9.11")
(version "1.15.0")
(source
(origin
(method git-fetch)
@ -1429,9 +1429,7 @@ as RetroArch.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "0hd77kw1f655s40qcz1righdhd9czqyy40rf7gigdag1bkchdx6z"))
(patches
(search-patches "retroarch-LIBRETRO_DIRECTORY.patch"))))
(base32 "1ii31mc7wfd386rzyxqk8nmx5a13f9iqz47991z4zx0d8gqcchzg"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@ -1449,13 +1447,6 @@ as RetroArch.")
(substitute* "gfx/common/wayland/generate_wayland_protos.sh"
(("/usr/local/share/wayland-protocols")
(string-append wayland-protocols "/share/wayland-protocols")))
(substitute* "qb/qb.libs.sh"
(("/bin/true") (which "true")))
;; Use shared zlib.
(substitute* '("libretro-common/file/archive_file_zlib.c"
"libretro-common/streams/trans_stream_zlib.c")
(("<compat/zlib.h>") "<zlib.h>"))
;; The configure script does not yet accept the extra arguments
;; (like CONFIG_SHELL=) passed by the default configure phase.
@ -1469,7 +1460,7 @@ as RetroArch.")
;; Non-free software are available through the core updater,
;; disable it. See <https://issues.guix.gnu.org/38360>.
"--disable-update_cores"
"--disable-builtinminiupnpc")))))))
"--disable-builtinzlib")))))))
(inputs
`(("alsa-lib" ,alsa-lib)
("ffmpeg" ,ffmpeg-4)
@ -1480,7 +1471,6 @@ as RetroArch.")
("libxrandr" ,libxrandr)
("libxv" ,libxv)
("mesa" ,mesa)
("miniupnpc" ,miniupnpc)
("openal" ,openal)
("pulseaudio" ,pulseaudio)
("python" ,python)

View File

@ -1,36 +0,0 @@
From 4c02c080475c9d08dbed98dd64ecca337aa359ae Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@member.fsf.org>
Date: Sat, 20 Feb 2021 20:37:39 +0800
Subject: [PATCH] Allow set libretro_directory via environment variable
---
retroarch.c | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)
diff --git a/retroarch.c b/retroarch.c
index 8a0461c816..cbf11d8b6a 100644
--- a/retroarch.c
+++ b/retroarch.c
@@ -17603,7 +17603,18 @@ static bool retroarch_parse_input_and_config(
p_rarch->configuration_settings->bools.log_to_file,
p_rarch->configuration_settings->bools.log_to_file_timestamp,
p_rarch->configuration_settings->paths.log_dir);
-
+
+ /* Override settings via environment variables */
+ {
+ settings_t *settings = p_rarch->configuration_settings;
+ char *value = getenv("LIBRETRO_DIRECTORY");
+ if (value != NULL)
+ {
+ retroarch_override_setting_set(RARCH_OVERRIDE_SETTING_LIBRETRO_DIRECTORY, NULL);
+ configuration_set_string(settings, settings->paths.directory_libretro, value);
+ }
+ }
+
/* Second pass: All other arguments override the config file */
optind = 1;
--
2.33.0