Merge branch 'master' into core-updates
Conflicts:
* gnu/packages/tls.scm (gnutls): Incorporated 3.5.13 graft (88e2511e21
).
This commit is contained in:
commit
5bace4c8ad
@ -44,6 +44,10 @@
|
|||||||
uuid->string
|
uuid->string
|
||||||
string->uuid
|
string->uuid
|
||||||
string->iso9660-uuid
|
string->iso9660-uuid
|
||||||
|
string->ext2-uuid
|
||||||
|
string->ext3-uuid
|
||||||
|
string->ext4-uuid
|
||||||
|
string->btrfs-uuid
|
||||||
|
|
||||||
bind-mount
|
bind-mount
|
||||||
|
|
||||||
@ -552,6 +556,11 @@ UUID representation."
|
|||||||
(time-low 4) (time-mid 2) (time-hi 2)
|
(time-low 4) (time-mid 2) (time-hi 2)
|
||||||
(clock-seq 2) (node 6)))))))
|
(clock-seq 2) (node 6)))))))
|
||||||
|
|
||||||
|
(define string->ext2-uuid string->uuid)
|
||||||
|
(define string->ext3-uuid string->uuid)
|
||||||
|
(define string->ext4-uuid string->uuid)
|
||||||
|
(define string->btrfs-uuid string->uuid)
|
||||||
|
|
||||||
|
|
||||||
(define* (canonicalize-device-spec spec #:optional (title 'any))
|
(define* (canonicalize-device-spec spec #:optional (title 'any))
|
||||||
"Return the device name corresponding to SPEC. TITLE is a symbol, one of
|
"Return the device name corresponding to SPEC. TITLE is a symbol, one of
|
||||||
|
@ -633,6 +633,8 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/gmp-faulty-test.patch \
|
%D%/packages/patches/gmp-faulty-test.patch \
|
||||||
%D%/packages/patches/gnome-tweak-tool-search-paths.patch \
|
%D%/packages/patches/gnome-tweak-tool-search-paths.patch \
|
||||||
%D%/packages/patches/gnucash-price-quotes-perl.patch \
|
%D%/packages/patches/gnucash-price-quotes-perl.patch \
|
||||||
|
%D%/packages/patches/gnutls-skip-trust-store-test.patch \
|
||||||
|
%D%/packages/patches/gnutls-skip-pkgconfig-test.patch \
|
||||||
%D%/packages/patches/gobject-introspection-absolute-shlib-path.patch \
|
%D%/packages/patches/gobject-introspection-absolute-shlib-path.patch \
|
||||||
%D%/packages/patches/gobject-introspection-cc.patch \
|
%D%/packages/patches/gobject-introspection-cc.patch \
|
||||||
%D%/packages/patches/gobject-introspection-girepository.patch \
|
%D%/packages/patches/gobject-introspection-girepository.patch \
|
||||||
|
@ -288,6 +288,38 @@ the GData protocol — most notably, Google's services. It provides APIs to
|
|||||||
access the common Google services, and has full asynchronous support.")
|
access the common Google services, and has full asynchronous support.")
|
||||||
(license license:lgpl2.1+)))
|
(license license:lgpl2.1+)))
|
||||||
|
|
||||||
|
(define-public libgxps
|
||||||
|
(package
|
||||||
|
(name "libgxps")
|
||||||
|
(version "0.2.5")
|
||||||
|
(source (origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (string-append "mirror://gnome/sources/" name "/"
|
||||||
|
(version-major+minor version) "/"
|
||||||
|
name "-" version ".tar.xz"))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"184r06s8g20cfigg7m169n42jjsc9wmzzlycr4g1fxxhr72r8x9y"))))
|
||||||
|
(build-system gnu-build-system)
|
||||||
|
(native-inputs
|
||||||
|
`(("gobject-introspection" ,gobject-introspection)
|
||||||
|
("pkg-config" ,pkg-config)))
|
||||||
|
(inputs
|
||||||
|
`(("cairo" ,cairo)
|
||||||
|
("glib" ,glib)
|
||||||
|
("libarchive" ,libarchive)
|
||||||
|
("libjpeg" ,libjpeg)
|
||||||
|
("lcms" ,lcms)
|
||||||
|
("libtiff" ,libtiff)
|
||||||
|
("nettle" ,nettle)))
|
||||||
|
(home-page "https://wiki.gnome.org/Projects/libgxps")
|
||||||
|
(synopsis "GObject-based library for handling and rendering XPS documents")
|
||||||
|
(description
|
||||||
|
"libgxps is a GObject-based library for handling and rendering XPS
|
||||||
|
documents. This package also contains binaries that can convert XPS documents
|
||||||
|
to other formats.")
|
||||||
|
(license license:lgpl2.1+)))
|
||||||
|
|
||||||
(define-public gnome-common
|
(define-public gnome-common
|
||||||
(package
|
(package
|
||||||
(name "gnome-common")
|
(name "gnome-common")
|
||||||
@ -593,13 +625,14 @@ forgotten when the session ends.")
|
|||||||
(("gtk-update-icon-cache") "true"))
|
(("gtk-update-icon-cache") "true"))
|
||||||
#t)))))
|
#t)))))
|
||||||
(inputs
|
(inputs
|
||||||
`(("libspectre" ,libspectre)
|
`(("libarchive" ,libarchive)
|
||||||
|
("libgxps" ,libgxps)
|
||||||
|
("libspectre" ,libspectre)
|
||||||
("djvulibre" ,djvulibre)
|
("djvulibre" ,djvulibre)
|
||||||
("ghostscript" ,ghostscript)
|
("ghostscript" ,ghostscript)
|
||||||
("poppler" ,poppler)
|
("poppler" ,poppler)
|
||||||
("libtiff" ,libtiff)
|
("libtiff" ,libtiff)
|
||||||
;; TODO:
|
;; TODO:
|
||||||
;; Add libgxps for XPS support.
|
|
||||||
;; Build libkpathsea as a shared library for DVI support.
|
;; Build libkpathsea as a shared library for DVI support.
|
||||||
;; ("libkpathsea" ,texlive-bin)
|
;; ("libkpathsea" ,texlive-bin)
|
||||||
("gnome-desktop" ,gnome-desktop)
|
("gnome-desktop" ,gnome-desktop)
|
||||||
|
@ -900,14 +900,14 @@ MIDI functionality to the Linux-based operating system.")
|
|||||||
(define-public alsa-utils
|
(define-public alsa-utils
|
||||||
(package
|
(package
|
||||||
(name "alsa-utils")
|
(name "alsa-utils")
|
||||||
(version "1.1.3")
|
(version "1.1.4")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "ftp://ftp.alsa-project.org/pub/utils/"
|
(uri (string-append "ftp://ftp.alsa-project.org/pub/utils/"
|
||||||
name "-" version ".tar.bz2"))
|
name "-" version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0z0nnqp1707bm02dys2d16m88lsg5nd26bqaf14rl3za9sjifwhj"))))
|
"17cxih9ibjp1193dyd79j50pyfa9dvrs6r9kpwrvzicjvr2110x7"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
;; XXX: Disable man page creation until we have DocBook.
|
;; XXX: Disable man page creation until we have DocBook.
|
||||||
@ -947,14 +947,14 @@ MIDI functionality to the Linux-based operating system.")
|
|||||||
(define-public alsa-plugins
|
(define-public alsa-plugins
|
||||||
(package
|
(package
|
||||||
(name "alsa-plugins")
|
(name "alsa-plugins")
|
||||||
(version "1.1.1")
|
(version "1.1.4")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "ftp://ftp.alsa-project.org/pub/plugins/"
|
(uri (string-append "ftp://ftp.alsa-project.org/pub/plugins/"
|
||||||
name "-" version ".tar.bz2"))
|
name "-" version ".tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1w81z5jlwqhd1l2m7qrq69lc4k9dnrg1wn52jsl2hrf3hbhd394f"))))
|
"12hsvm6rpinjkg06pa9hzndkdrbfw6wk6yk00cm8y1gbv8xiq3ak"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
;; TODO: Split libavcodec and speex if possible. It looks like they can not
|
;; TODO: Split libavcodec and speex if possible. It looks like they can not
|
||||||
;; be split, there are references to both in files.
|
;; be split, there are references to both in files.
|
||||||
|
24
gnu/packages/patches/gnutls-skip-pkgconfig-test.patch
Normal file
24
gnu/packages/patches/gnutls-skip-pkgconfig-test.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
FIXME: The static test fails with an error such as:
|
||||||
|
|
||||||
|
/tmp/guix-build-gnutls-3.5.13.drv-0/ccOnGPmc.o: In function `main':
|
||||||
|
c.29617.tmp.c:(.text+0x5): undefined reference to `gnutls_global_init'
|
||||||
|
collect2: error: ld returned 1 exit status
|
||||||
|
FAIL pkgconfig.sh (exit status: 1)
|
||||||
|
|
||||||
|
diff --git a/tests/pkgconfig.sh b/tests/pkgconfig.sh
|
||||||
|
index 6bd4e62f9..05aab8278 100755
|
||||||
|
--- a/tests/pkgconfig.sh
|
||||||
|
+++ b/tests/pkgconfig.sh
|
||||||
|
@@ -57,11 +57,7 @@ echo "Trying dynamic linking with:"
|
||||||
|
echo " * flags: $(${PKGCONFIG} --libs gnutls)"
|
||||||
|
echo " * common: ${COMMON}"
|
||||||
|
echo " * lib: ${CFLAGS}"
|
||||||
|
-cc ${TMPFILE} -o ${TMPFILE_O} $(${PKGCONFIG} --libs gnutls) $(${PKGCONFIG} --cflags gnutls) ${COMMON}
|
||||||
|
-
|
||||||
|
-echo ""
|
||||||
|
-echo "Trying static linking with $(${PKGCONFIG} --libs --static gnutls)"
|
||||||
|
-cc ${TMPFILE} -o ${TMPFILE_O} $(${PKGCONFIG} --static --libs gnutls) $(${PKGCONFIG} --cflags gnutls) ${COMMON}
|
||||||
|
+gcc ${TMPFILE} -o ${TMPFILE_O} $(${PKGCONFIG} --libs gnutls) $(${PKGCONFIG} --cflags gnutls) ${COMMON}
|
||||||
|
|
||||||
|
rm -f ${TMPFILE} ${TMPFILE_O}
|
||||||
|
|
15
gnu/packages/patches/gnutls-skip-trust-store-test.patch
Normal file
15
gnu/packages/patches/gnutls-skip-trust-store-test.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
Version 3.5.11 added a test to check that the default trust store is readable.
|
||||||
|
It does not exist in the build environment, so pretend everything is fine.
|
||||||
|
|
||||||
|
diff a/tests/trust-store.c b/tests/trust-store.c
|
||||||
|
--- a/tests/trust-store.c
|
||||||
|
+++ b/tests/trust-store.c
|
||||||
|
@@ -61,7 +61,7 @@
|
||||||
|
} else if (ret < 0) {
|
||||||
|
fail("error loading system trust store: %s\n", gnutls_strerror(ret));
|
||||||
|
} else if (ret == 0) {
|
||||||
|
- fail("no certificates were found in system trust store!\n");
|
||||||
|
+ success("no trust store in the Guix build environment!\n");
|
||||||
|
}
|
||||||
|
|
||||||
|
gnutls_certificate_free_credentials(x509_cred);
|
@ -15294,3 +15294,28 @@ from your Flask project. It is a fork of Flask-Swagger.")
|
|||||||
|
|
||||||
(define-public python2-flasgger
|
(define-public python2-flasgger
|
||||||
(package-with-python2 python-flasgger))
|
(package-with-python2 python-flasgger))
|
||||||
|
|
||||||
|
(define-public python-swagger-spec-validator
|
||||||
|
(package
|
||||||
|
(name "python-swagger-spec-validator")
|
||||||
|
(version "2.1.0")
|
||||||
|
(source
|
||||||
|
(origin
|
||||||
|
(method url-fetch)
|
||||||
|
(uri (pypi-uri "swagger-spec-validator" version))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"13hkpn2lycwr0468yqhjb3kwszqf7hjwlq61w7vdxq1caz31k4nw"))))
|
||||||
|
(build-system python-build-system)
|
||||||
|
(propagated-inputs
|
||||||
|
`(("python-jsonschema" ,python-jsonschema)
|
||||||
|
("python-six" ,python-six)))
|
||||||
|
(home-page
|
||||||
|
"http://github.com/Yelp/swagger_spec_validator")
|
||||||
|
(synopsis "Validation of Swagger specifications")
|
||||||
|
(description "@code{swagger_spec_validator} provides a library for
|
||||||
|
validating Swagger API specifications.")
|
||||||
|
(license license:asl2.0)))
|
||||||
|
|
||||||
|
(define-public python2-swagger-spec-validator
|
||||||
|
(package-with-python2 python-swagger-spec-validator))
|
||||||
|
@ -9,6 +9,7 @@
|
|||||||
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
|
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
|
||||||
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
|
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
|
||||||
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
|
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
|
||||||
|
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
@ -133,7 +134,7 @@ living in the same process.")
|
|||||||
(define-public gnutls
|
(define-public gnutls
|
||||||
(package
|
(package
|
||||||
(name "gnutls")
|
(name "gnutls")
|
||||||
(version "3.5.10")
|
(version "3.5.13")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri
|
(uri
|
||||||
@ -142,9 +143,12 @@ living in the same process.")
|
|||||||
(string-append "mirror://gnupg/gnutls/v"
|
(string-append "mirror://gnupg/gnutls/v"
|
||||||
(version-major+minor version)
|
(version-major+minor version)
|
||||||
"/gnutls-" version ".tar.xz"))
|
"/gnutls-" version ".tar.xz"))
|
||||||
|
(patches
|
||||||
|
(search-patches "gnutls-skip-trust-store-test.patch"
|
||||||
|
"gnutls-skip-pkgconfig-test.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"17apwvdkkazh5w8z8mbanpj2yj8s2002qwy46wz4v3akpa33wi5g"))))
|
"15ihq6p0hnnhs8cnjrkj40dmlcaa1jjg8xg0g2ydbnlqs454ixbr"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:configure-flags
|
'(#:configure-flags
|
||||||
|
@ -43,14 +43,14 @@
|
|||||||
(define-public tor
|
(define-public tor
|
||||||
(package
|
(package
|
||||||
(name "tor")
|
(name "tor")
|
||||||
(version "0.3.0.7")
|
(version "0.3.0.8")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://dist.torproject.org/tor-"
|
(uri (string-append "https://dist.torproject.org/tor-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"00kxa83bn0axh7479fynp6r8znq5wy26kvb8ghixgjpkir2c8h4n"))))
|
"0j0dhq1zp6w6zy7y4kiw7zg1imbgv8nsl7imlzwc0951p2kknfk6"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags (list "--enable-expensive-hardening"
|
`(#:configure-flags (list "--enable-expensive-hardening"
|
||||||
|
@ -1449,6 +1449,7 @@ filtering and encoding tasks. It supports many file types, including AVI,
|
|||||||
DVD compatible MPEG files, MP4 and ASF, using a variety of codecs. Tasks
|
DVD compatible MPEG files, MP4 and ASF, using a variety of codecs. Tasks
|
||||||
can be automated using projects, job queue and powerful scripting
|
can be automated using projects, job queue and powerful scripting
|
||||||
capabilities.")
|
capabilities.")
|
||||||
|
(supported-systems '("x86_64-linux" "i686-linux" "armhf-linux"))
|
||||||
;; Software with various licenses is included, see License.txt.
|
;; Software with various licenses is included, see License.txt.
|
||||||
(license license:gpl2+)))
|
(license license:gpl2+)))
|
||||||
|
|
||||||
|
@ -55,14 +55,14 @@
|
|||||||
(define-public wine
|
(define-public wine
|
||||||
(package
|
(package
|
||||||
(name "wine")
|
(name "wine")
|
||||||
(version "2.9")
|
(version "2.10")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://dl.winehq.org/wine/source/2.x"
|
(uri (string-append "https://dl.winehq.org/wine/source/2.x"
|
||||||
"/wine-" version ".tar.xz"))
|
"/wine-" version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0pslhs3kwjimlz5ad6vzzdw7lgbfpwl8vyg4jmf17p61pfxzfimc"))))
|
"0ygiaayi2mv6jl450d03i4x2gd2bg3mwk3s2pxas87g8sbzzg3a8"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs `(("pkg-config" ,pkg-config)
|
(native-inputs `(("pkg-config" ,pkg-config)
|
||||||
("gettext" ,gettext-minimal)
|
("gettext" ,gettext-minimal)
|
||||||
|
@ -55,6 +55,7 @@
|
|||||||
#:use-module (gnu packages gl)
|
#:use-module (gnu packages gl)
|
||||||
#:use-module (gnu packages glib)
|
#:use-module (gnu packages glib)
|
||||||
#:use-module (gnu packages gnome)
|
#:use-module (gnu packages gnome)
|
||||||
|
#:use-module (gnu packages icu4c)
|
||||||
#:use-module (gnu packages maths)
|
#:use-module (gnu packages maths)
|
||||||
#:use-module (gnu packages m4)
|
#:use-module (gnu packages m4)
|
||||||
#:use-module (gnu packages ncurses)
|
#:use-module (gnu packages ncurses)
|
||||||
@ -449,7 +450,7 @@ of the screen selected by mouse.")
|
|||||||
(define-public slop
|
(define-public slop
|
||||||
(package
|
(package
|
||||||
(name "slop")
|
(name "slop")
|
||||||
(version "6.3.43")
|
(version "6.3.45")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
@ -458,12 +459,13 @@ of the screen selected by mouse.")
|
|||||||
(file-name (string-append name "-" version ".tar.gz"))
|
(file-name (string-append name "-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0kazcnnarc61d3rjysaym9vadf31wisfd3sn076rsjnsldm4y66h"))))
|
"0lzyjcg6yff1vzlsda45i57khajp56yrmcjfa5faw3i60fnqqiy7"))))
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:tests? #f)) ; no "check" target
|
'(#:tests? #f)) ; no "check" target
|
||||||
(inputs
|
(inputs
|
||||||
`(("glm" ,glm)
|
`(("glm" ,glm)
|
||||||
|
("icu4c" ,icu4c)
|
||||||
("libxext" ,libxext)
|
("libxext" ,libxext)
|
||||||
("libxrender" ,libxrender)
|
("libxrender" ,libxrender)
|
||||||
("mesa" ,mesa)))
|
("mesa" ,mesa)))
|
||||||
|
@ -104,7 +104,7 @@
|
|||||||
boot-parameters?
|
boot-parameters?
|
||||||
boot-parameters-label
|
boot-parameters-label
|
||||||
boot-parameters-root-device
|
boot-parameters-root-device
|
||||||
boot-parameters-boot-name
|
boot-parameters-bootloader-name
|
||||||
boot-parameters-store-device
|
boot-parameters-store-device
|
||||||
boot-parameters-store-mount-point
|
boot-parameters-store-mount-point
|
||||||
boot-parameters-kernel
|
boot-parameters-kernel
|
||||||
@ -216,7 +216,7 @@ directly by the user."
|
|||||||
;; exactly to the device field of the <file-system> object representing the
|
;; exactly to the device field of the <file-system> object representing the
|
||||||
;; OS's root file system, so it might be a device path like "/dev/sda3".
|
;; OS's root file system, so it might be a device path like "/dev/sda3".
|
||||||
(root-device boot-parameters-root-device)
|
(root-device boot-parameters-root-device)
|
||||||
(boot-name boot-parameters-boot-name)
|
(bootloader-name boot-parameters-bootloader-name)
|
||||||
(store-device boot-parameters-store-device)
|
(store-device boot-parameters-store-device)
|
||||||
(store-mount-point boot-parameters-store-mount-point)
|
(store-mount-point boot-parameters-store-mount-point)
|
||||||
(kernel boot-parameters-kernel)
|
(kernel boot-parameters-kernel)
|
||||||
@ -235,8 +235,8 @@ directly by the user."
|
|||||||
(label label)
|
(label label)
|
||||||
(root-device root)
|
(root-device root)
|
||||||
|
|
||||||
(boot-name
|
(bootloader-name
|
||||||
(match (assq 'boot-name rest)
|
(match (assq 'bootloader-name rest)
|
||||||
((_ args) args)
|
((_ args) args)
|
||||||
(#f 'grub))) ; for compatibility reasons.
|
(#f 'grub))) ; for compatibility reasons.
|
||||||
|
|
||||||
@ -306,7 +306,7 @@ The object has its kernel-arguments extended in order to make it bootable."
|
|||||||
(boot-parameters
|
(boot-parameters
|
||||||
(label (menu-entry-label menu-entry))
|
(label (menu-entry-label menu-entry))
|
||||||
(root-device #f)
|
(root-device #f)
|
||||||
(boot-name 'custom)
|
(bootloader-name 'custom)
|
||||||
(store-device #f)
|
(store-device #f)
|
||||||
(store-mount-point #f)
|
(store-mount-point #f)
|
||||||
(kernel (menu-entry-linux menu-entry))
|
(kernel (menu-entry-linux menu-entry))
|
||||||
@ -892,7 +892,7 @@ kernel arguments for that derivation to <boot-parameters>."
|
|||||||
(store -> (operating-system-store-file-system os))
|
(store -> (operating-system-store-file-system os))
|
||||||
(bootloader -> (bootloader-configuration-bootloader
|
(bootloader -> (bootloader-configuration-bootloader
|
||||||
(operating-system-bootloader os)))
|
(operating-system-bootloader os)))
|
||||||
(boot-name -> (bootloader-name bootloader))
|
(bootloader-name -> (bootloader-name bootloader))
|
||||||
(label -> (kernel->boot-label (operating-system-kernel os))))
|
(label -> (kernel->boot-label (operating-system-kernel os))))
|
||||||
(return (boot-parameters
|
(return (boot-parameters
|
||||||
(label label)
|
(label label)
|
||||||
@ -903,7 +903,7 @@ kernel arguments for that derivation to <boot-parameters>."
|
|||||||
(operating-system-kernel-arguments os system.drv root-device)
|
(operating-system-kernel-arguments os system.drv root-device)
|
||||||
(operating-system-user-kernel-arguments os)))
|
(operating-system-user-kernel-arguments os)))
|
||||||
(initrd initrd)
|
(initrd initrd)
|
||||||
(boot-name boot-name)
|
(bootloader-name bootloader-name)
|
||||||
(store-device (fs->boot-device store))
|
(store-device (fs->boot-device store))
|
||||||
(store-mount-point (file-system-mount-point store))))))
|
(store-mount-point (file-system-mount-point store))))))
|
||||||
|
|
||||||
@ -929,7 +929,7 @@ being stored into the \"parameters\" file)."
|
|||||||
(kernel-arguments
|
(kernel-arguments
|
||||||
#$(boot-parameters-kernel-arguments params))
|
#$(boot-parameters-kernel-arguments params))
|
||||||
(initrd #$(boot-parameters-initrd params))
|
(initrd #$(boot-parameters-initrd params))
|
||||||
(boot-name #$(boot-parameters-boot-name params))
|
(bootloader-name #$(boot-parameters-bootloader-name params))
|
||||||
(store
|
(store
|
||||||
(device #$(boot-parameters-store-device params))
|
(device #$(boot-parameters-store-device params))
|
||||||
(mount-point #$(boot-parameters-store-mount-point params))))
|
(mount-point #$(boot-parameters-store-mount-point params))))
|
||||||
|
@ -425,7 +425,7 @@ generation as its default entry. STORE is an open connection to the store."
|
|||||||
"Return the bootloader name stored in SYSTEM's \"parameters\" file."
|
"Return the bootloader name stored in SYSTEM's \"parameters\" file."
|
||||||
(let ((params (unless-file-not-found
|
(let ((params (unless-file-not-found
|
||||||
(read-boot-parameters-file system))))
|
(read-boot-parameters-file system))))
|
||||||
(boot-parameters-boot-name params)))
|
(boot-parameters-bootloader-name params)))
|
||||||
|
|
||||||
(define (reinstall-bootloader store number)
|
(define (reinstall-bootloader store number)
|
||||||
"Re-install bootloader for existing system profile generation NUMBER.
|
"Re-install bootloader for existing system profile generation NUMBER.
|
||||||
@ -521,7 +521,7 @@ list of services."
|
|||||||
(let* ((generation (generation-file-name profile number))
|
(let* ((generation (generation-file-name profile number))
|
||||||
(params (read-boot-parameters-file generation))
|
(params (read-boot-parameters-file generation))
|
||||||
(label (boot-parameters-label params))
|
(label (boot-parameters-label params))
|
||||||
(boot-name (boot-parameters-boot-name params))
|
(bootloader-name (boot-parameters-bootloader-name params))
|
||||||
(root (boot-parameters-root-device params))
|
(root (boot-parameters-root-device params))
|
||||||
(root-device (if (bytevector? root)
|
(root-device (if (bytevector? root)
|
||||||
(uuid->string root)
|
(uuid->string root)
|
||||||
@ -532,7 +532,7 @@ list of services."
|
|||||||
(format #t (G_ " canonical file name: ~a~%") (readlink* generation))
|
(format #t (G_ " canonical file name: ~a~%") (readlink* generation))
|
||||||
;; TRANSLATORS: Please preserve the two-space indentation.
|
;; TRANSLATORS: Please preserve the two-space indentation.
|
||||||
(format #t (G_ " label: ~a~%") label)
|
(format #t (G_ " label: ~a~%") label)
|
||||||
(format #t (G_ " bootloader: ~a~%") boot-name)
|
(format #t (G_ " bootloader: ~a~%") bootloader-name)
|
||||||
(format #t (G_ " root device: ~a~%") root-device)
|
(format #t (G_ " root device: ~a~%") root-device)
|
||||||
(format #t (G_ " kernel: ~a~%") kernel))))
|
(format #t (G_ " kernel: ~a~%") kernel))))
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user