gnu: ledger: Fix test failures.
* gnu/packages/patches/ledger-revert-boost-python-fix.patch, gnu/packages/patches/ledger-fix-uninitialized.patch: New patches. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/finance.scm (ledger)[source]: Use them.
This commit is contained in:
parent
7f9866a312
commit
5424f9bcab
@ -794,6 +794,8 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/ldc-disable-tests.patch \
|
||||
%D%/packages/patches/ldc-1.1.0-disable-dmd-tests.patch \
|
||||
%D%/packages/patches/ldc-1.1.0-disable-phobos-tests.patch \
|
||||
%D%/packages/patches/ledger-fix-uninitialized.patch \
|
||||
%D%/packages/patches/ledger-revert-boost-python-fix.patch \
|
||||
%D%/packages/patches/liba52-enable-pic.patch \
|
||||
%D%/packages/patches/liba52-link-with-libm.patch \
|
||||
%D%/packages/patches/liba52-set-soname.patch \
|
||||
|
@ -6,6 +6,7 @@
|
||||
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
|
||||
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
|
||||
;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
|
||||
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
@ -29,6 +30,7 @@
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (guix build-system cmake)
|
||||
#:use-module (guix build-system python)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages base)
|
||||
#:use-module (gnu packages boost)
|
||||
#:use-module (gnu packages check)
|
||||
@ -130,7 +132,9 @@ line client and a client based on Qt.")
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"12jlv3gsjhrja25q9hrwh73cdacd2l3c2yyn8qnijav9mdhnbw4h"))))
|
||||
"12jlv3gsjhrja25q9hrwh73cdacd2l3c2yyn8qnijav9mdhnbw4h"))
|
||||
(patches (search-patches "ledger-revert-boost-python-fix.patch"
|
||||
"ledger-fix-uninitialized.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:modules ((guix build cmake-build-system)
|
||||
|
27
gnu/packages/patches/ledger-fix-uninitialized.patch
Normal file
27
gnu/packages/patches/ledger-fix-uninitialized.patch
Normal file
@ -0,0 +1,27 @@
|
||||
This fixes failures of tests "BaseLine_opt-datetime-format" and
|
||||
"BaseLine_opt-time-report", which were printing an unexpected trailing '*' on
|
||||
the last line of output, e.g.:
|
||||
|
||||
@@ -5,4 +5,4 @@
|
||||
04/05/13 12:00 PM 04/05/13 01:30 PM 1.50h Lunch
|
||||
04/05/13 11:30 AM 04/05/13 12:00 PM 30.0m Walk
|
||||
--------------------------------------------------
|
||||
-
|
||||
+ *
|
||||
|
||||
Reported upstream at
|
||||
https://groups.google.com/d/msg/ledger-cli/EeJUrUk8YDc/pIR-LOTVEAAJ
|
||||
|
||||
diff --git a/src/account.h b/src/account.h
|
||||
index 1b97463d..f2555593 100644
|
||||
--- a/src/account.h
|
||||
+++ b/src/account.h
|
||||
@@ -187,7 +187,7 @@ public:
|
||||
|
||||
datetime_t earliest_checkin;
|
||||
datetime_t latest_checkout;
|
||||
- bool latest_checkout_cleared;
|
||||
+ bool latest_checkout_cleared = false;
|
||||
|
||||
std::set<path> filenames;
|
||||
std::set<string> accounts_referenced;
|
39
gnu/packages/patches/ledger-revert-boost-python-fix.patch
Normal file
39
gnu/packages/patches/ledger-revert-boost-python-fix.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From 01220484f428a447e9b00e071a0d85185f30e1de Mon Sep 17 00:00:00 2001
|
||||
From: Alexis Hildebrandt <afh@surryhill.net>
|
||||
Date: Wed, 22 Jun 2016 15:43:37 +0200
|
||||
Subject: [PATCH] Revert "[python] Add fix for Boost.Python compile errors"
|
||||
|
||||
This reverts commit 11590e134eafa768ccc4a171cc7fb216e906095f.
|
||||
---
|
||||
src/py_commodity.cc | 3 ---
|
||||
src/py_journal.cc | 3 ---
|
||||
2 files changed, 6 deletions(-)
|
||||
|
||||
diff --git a/src/py_commodity.cc b/src/py_commodity.cc
|
||||
index 5aafa6c..c457e64 100644
|
||||
--- a/src/py_commodity.cc
|
||||
+++ b/src/py_commodity.cc
|
||||
@@ -243,9 +243,6 @@ namespace {
|
||||
|
||||
void export_commodity()
|
||||
{
|
||||
-#if BOOST_VERSION >= 106000
|
||||
- python::register_ptr_to_python< shared_ptr<commodity_pool_t> >();
|
||||
-#endif
|
||||
class_< commodity_pool_t, shared_ptr<commodity_pool_t>,
|
||||
boost::noncopyable > ("CommodityPool", no_init)
|
||||
.add_property("null_commodity",
|
||||
diff --git a/src/py_journal.cc b/src/py_journal.cc
|
||||
index c1c38a9..879f954 100644
|
||||
--- a/src/py_journal.cc
|
||||
+++ b/src/py_journal.cc
|
||||
@@ -232,9 +232,6 @@ void export_journal()
|
||||
boost::noncopyable >("PostHandler")
|
||||
;
|
||||
|
||||
-#if BOOST_VERSION >= 106000
|
||||
- python::register_ptr_to_python< shared_ptr<collector_wrapper> >();
|
||||
-#endif
|
||||
class_< collector_wrapper, shared_ptr<collector_wrapper>,
|
||||
boost::noncopyable >("PostCollectorWrapper", no_init)
|
||||
.def("__len__", &collector_wrapper::length)
|
Loading…
Reference in New Issue
Block a user