gnu: llvm-17: Fix building on riscv64-linux.

* gnu/packages/llvm.scm (%llvm-patches): Add a patch for 17.0.6.
* gnu/packages/patches/clang-17.0-link-dsymutil-latomic.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.

Change-Id: I9dfd23d2f0fb10620c4aa73a6480151d6e6daa9a
This commit is contained in:
Efraim Flashner 2024-03-13 17:30:56 +02:00
parent 7b5c030684
commit 4e26331a5e
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 17 additions and 1 deletions

View File

@ -1042,6 +1042,7 @@ dist_patch_DATA = \
%D%/packages/patches/clang-15.0-libc-search-path.patch \
%D%/packages/patches/clang-16.0-libc-search-path.patch \
%D%/packages/patches/clang-17.0-libc-search-path.patch \
%D%/packages/patches/clang-17.0-link-dsymutil-latomic.patch \
%D%/packages/patches/clang-runtime-asan-build-fixes.patch \
%D%/packages/patches/clang-runtime-esan-build-fixes.patch \
%D%/packages/patches/clang-runtime-9-libsanitizer-mode-field.patch \

View File

@ -550,7 +550,8 @@ output), and Binutils.")
'(("14.0.6" . ("clang-14.0-libc-search-path.patch"))
("15.0.7" . ("clang-15.0-libc-search-path.patch"))
("16.0.6" . ("clang-16.0-libc-search-path.patch"))
("17.0.6" . ("clang-17.0-libc-search-path.patch"))))
("17.0.6" . ("clang-17.0-libc-search-path.patch"
"clang-17.0-link-dsymutil-latomic.patch"))))
(define (llvm-monorepo version)
(origin

View File

@ -0,0 +1,14 @@
This was mistakenly added to llvm-17 while a patch was being rebased.
---
diff --git a/llvm/tools/dsymutil/CMakeLists.txt b/llvm/tools/dsymutil/CMakeLists.txt
index 3cb88a50ce25..8699d0bb1d6b 100644
--- a/llvm/tools/dsymutil/CMakeLists.txt
+++ b/llvm/tools/dsymutil/CMakeLists.txt
@@ -42,4 +42,4 @@ if(APPLE)
target_link_libraries(dsymutil PRIVATE "-framework CoreFoundation")
endif(APPLE)
-# target_link_libraries(dsymutil PRIVATE ${LLVM_ATOMIC_LIB})
+target_link_libraries(dsymutil PRIVATE ${LLVM_ATOMIC_LIB})