gnu: konversation: Update to 1.7.6.
* gnu/packages/kde-internet.scm (konversation): Update to 1.7.6. [source]: Remove obsolete patch. * gnu/packages/patches/konversation-Fix-build-with-Qt-5.11.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
9d1afee51c
commit
40dfc5195f
@ -1204,7 +1204,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/kodi-increase-test-timeout.patch \
|
||||
%D%/packages/patches/kodi-set-libcurl-ssl-parameters.patch \
|
||||
%D%/packages/patches/kodi-skip-test-449.patch \
|
||||
%D%/packages/patches/konversation-Fix-build-with-Qt-5.11.patch \
|
||||
%D%/packages/patches/laby-make-install.patch \
|
||||
%D%/packages/patches/lcalc-default-parameters-1.patch \
|
||||
%D%/packages/patches/lcalc-default-parameters-2.patch \
|
||||
|
@ -1,5 +1,6 @@
|
||||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
|
||||
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
@ -177,15 +178,14 @@ This package is part of the KDE networking module.")
|
||||
(define-public konversation
|
||||
(package
|
||||
(name "konversation")
|
||||
(version "1.7.5")
|
||||
(version "1.7.6")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://kde/stable/konversation/" version
|
||||
"/src/konversation-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32 "0h098yhlp36ls6pdvs2r93ig8dv4fys62m0h6wxccprb0qrpbgv0"))
|
||||
(patches (search-patches "konversation-Fix-build-with-Qt-5.11.patch"))))
|
||||
(base32 "14x0rs867grb1xjddycn9l6bfl3h3rp4cmx4zqd2gsvkihn4zlpx"))))
|
||||
(build-system qt-build-system)
|
||||
(native-inputs
|
||||
`(("extra-cmake-modules" ,extra-cmake-modules)
|
||||
|
@ -1,24 +0,0 @@
|
||||
From 4d0036617becc26a76fd021138c98aceec4c7b53 Mon Sep 17 00:00:00 2001
|
||||
From: Luca Beltrame <lbeltrame@kde.org>
|
||||
Date: Sun, 21 Jul 2019 09:14:32 +0200
|
||||
Subject: Fix build with Qt 5.13
|
||||
|
||||
---
|
||||
src/irc/outputfilter.cpp | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/irc/outputfilter.cpp b/src/irc/outputfilter.cpp
|
||||
index f9e6253..45d11fb 100644
|
||||
--- a/src/irc/outputfilter.cpp
|
||||
+++ b/src/irc/outputfilter.cpp
|
||||
@@ -32,6 +32,7 @@
|
||||
|
||||
#include <QStringList>
|
||||
#include <QFile>
|
||||
+#include <QMetaMethod>
|
||||
#include <QRegExp>
|
||||
#include <QTextCodec>
|
||||
#include <QByteArray>
|
||||
--
|
||||
cgit v1.1
|
||||
|
Loading…
Reference in New Issue
Block a user