gnu: glslang: Update to 1.3.280.0.
* gnu/packages/vulkan.scm (glslang): Update to 1.3.280.0. [source]: Remove patch. [arguments]: Run tests. [inputs]: Add spirv-tools. * gnu/packages/patches/glslang-install-static-libs.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Ungerister it. Change-Id: I39ef23565e575179b292a1ab76d2d70c98f84767 Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
This commit is contained in:
parent
fb5299f54c
commit
408a770c8f
@ -1360,7 +1360,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/glibc-2.29-git-updates.patch \
|
||||
%D%/packages/patches/glibc-2.29-supported-locales.patch \
|
||||
%D%/packages/patches/glibc-supported-locales.patch \
|
||||
%D%/packages/patches/glslang-install-static-libs.patch \
|
||||
%D%/packages/patches/gmobile-make-it-installable.patch \
|
||||
%D%/packages/patches/gmp-arm-asm-nothumb.patch \
|
||||
%D%/packages/patches/gmp-faulty-test.patch \
|
||||
|
@ -1,61 +0,0 @@
|
||||
Install OGLCompiler et.al. even when building shared libraries. Also fix
|
||||
CMake file locations.
|
||||
|
||||
Patch taken from Gentoo:
|
||||
|
||||
https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-util/glslang/files/glslang-1.3.231-Install-static-libs.patch
|
||||
|
||||
diff --git a/OGLCompilersDLL/CMakeLists.txt b/OGLCompilersDLL/CMakeLists.txt
|
||||
--- a/OGLCompilersDLL/CMakeLists.txt
|
||||
+++ b/OGLCompilersDLL/CMakeLists.txt
|
||||
@@ -41,7 +41,7 @@ if(WIN32)
|
||||
source_group("Source" FILES ${SOURCES})
|
||||
endif(WIN32)
|
||||
|
||||
-if(ENABLE_GLSLANG_INSTALL AND NOT BUILD_SHARED_LIBS)
|
||||
+if(ENABLE_GLSLANG_INSTALL)
|
||||
install(TARGETS OGLCompiler EXPORT glslang-targets)
|
||||
|
||||
# Backward compatibility
|
||||
@@ -49,7 +49,7 @@ if(ENABLE_GLSLANG_INSTALL AND NOT BUILD_SHARED_LIBS)
|
||||
message(WARNING \"Using `OGLCompilerTargets.cmake` is deprecated: use `find_package(glslang)` to find glslang CMake targets.\")
|
||||
|
||||
if (NOT TARGET glslang::OGLCompiler)
|
||||
- include(\"\${CMAKE_CURRENT_LIST_DIR}/../../${CMAKE_INSTALL_LIBDIR}/${PROJECT_NAME}/glslang-targets.cmake\")
|
||||
+ include(\"\${CMAKE_CURRENT_LIST_DIR}/../../${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}/glslang-targets.cmake\")
|
||||
endif()
|
||||
|
||||
add_library(OGLCompiler ALIAS glslang::OGLCompiler)
|
||||
diff --git a/glslang/CMakeLists.txt b/glslang/CMakeLists.txt
|
||||
--- a/glslang/CMakeLists.txt
|
||||
+++ b/glslang/CMakeLists.txt
|
||||
@@ -203,7 +203,7 @@ endif()
|
||||
################################################################################
|
||||
if(ENABLE_GLSLANG_INSTALL)
|
||||
install(TARGETS glslang EXPORT glslang-targets)
|
||||
- if(NOT BUILD_SHARED_LIBS)
|
||||
+ if(BUILD_SHARED_LIBS)
|
||||
install(TARGETS MachineIndependent EXPORT glslang-targets)
|
||||
install(TARGETS GenericCodeGen EXPORT glslang-targets)
|
||||
|
||||
diff --git a/glslang/OSDependent/Unix/CMakeLists.txt b/glslang/OSDependent/Unix/CMakeLists.txt
|
||||
--- a/glslang/OSDependent/Unix/CMakeLists.txt
|
||||
+++ b/glslang/OSDependent/Unix/CMakeLists.txt
|
||||
@@ -52,7 +52,7 @@ else()
|
||||
target_link_libraries(OSDependent Threads::Threads)
|
||||
endif()
|
||||
|
||||
-if(ENABLE_GLSLANG_INSTALL AND NOT BUILD_SHARED_LIBS)
|
||||
+if(ENABLE_GLSLANG_INSTALL)
|
||||
install(TARGETS OSDependent EXPORT glslang-targets)
|
||||
|
||||
# Backward compatibility
|
||||
@@ -60,7 +60,7 @@ if(ENABLE_GLSLANG_INSTALL AND NOT BUILD_SHARED_LIBS)
|
||||
message(WARNING \"Using `OSDependentTargets.cmake` is deprecated: use `find_package(glslang)` to find glslang CMake targets.\")
|
||||
|
||||
if (NOT TARGET glslang::OSDependent)
|
||||
- include(\"\${CMAKE_CURRENT_LIST_DIR}/../../${CMAKE_INSTALL_LIBDIR}/${PROJECT_NAME}/glslang-targets.cmake\")
|
||||
+ include(\"\${CMAKE_CURRENT_LIST_DIR}/../../${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}/glslang-targets.cmake\")
|
||||
endif()
|
||||
|
||||
add_library(OSDependent ALIAS glslang::OSDependent)
|
@ -189,22 +189,27 @@ translation between LLVM IR and SPIR-V.")
|
||||
(define-public glslang
|
||||
(package
|
||||
(name "glslang")
|
||||
(version %vulkan-sdk-version)
|
||||
(version "1.3.280.0")
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/KhronosGroup/glslang")
|
||||
(commit version)))
|
||||
(patches (search-patches "glslang-install-static-libs.patch"))
|
||||
(commit (string-append "vulkan-sdk-" version))))
|
||||
(sha256
|
||||
(base32
|
||||
"12a1zl8qxa28nbf6m67260c0lwdw3bqbj0jz1382wgm5px1fpqw6"))
|
||||
"1vvgqvwhsimlz8wkk38b9cvp9abggq840iws8al0znzz3mnvkfdn"))
|
||||
(file-name (git-file-name name version))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
'(#:tests? #f ;FIXME: requires bundled SPIRV-Tools
|
||||
#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
|
||||
'(#:configure-flags '("-DBUILD_SHARED_LIBS=ON"
|
||||
"-DALLOW_EXTERNAL_SPIRV_TOOLS=ON")
|
||||
#:phases (modify-phases %standard-phases
|
||||
(replace 'check
|
||||
(lambda* (#:key tests? #:allow-other-keys)
|
||||
(when tests?
|
||||
(invoke "ctest")))))))
|
||||
(inputs (list spirv-tools))
|
||||
(native-inputs
|
||||
(list pkg-config python))
|
||||
(home-page "https://github.com/KhronosGroup/glslang")
|
||||
|
Loading…
Reference in New Issue
Block a user