gnu: gcc@5: Update to 5.5.0.
* gnu/packages/gcc.scm (gcc@5): Update to 5.5.0. [source]: Switch to '.tar.xz' tarball. Remove patch. * gnu/packages/patches/gcc-asan-powerpc-missing-include.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
c3a3fdd22e
commit
404e3d8b1b
@ -625,7 +625,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/gawk-shell.patch \
|
||||
%D%/packages/patches/gcc-arm-bug-71399.patch \
|
||||
%D%/packages/patches/gcc-arm-link-spec-fix.patch \
|
||||
%D%/packages/patches/gcc-asan-powerpc-missing-include.patch \
|
||||
%D%/packages/patches/gcc-cross-environment-variables.patch \
|
||||
%D%/packages/patches/gcc-fix-texi2pod.patch \
|
||||
%D%/packages/patches/gcc-libvtv-runpath.patch \
|
||||
|
@ -382,17 +382,16 @@ Go. It also includes runtime support libraries for these languages.")
|
||||
;; Note: GCC >= 5 ships with .info files but 'make install' fails to install
|
||||
;; them in a VPATH build.
|
||||
(package (inherit gcc-4.9)
|
||||
(version "5.4.0")
|
||||
(version "5.5.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/gcc/gcc-"
|
||||
version "/gcc-" version ".tar.bz2"))
|
||||
version "/gcc-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0fihlcy5hnksdxk0sn6bvgnyq8gfrgs8m794b1jxwd1dxinzg3b0"))
|
||||
"11zd1hgzkli3b2v70qsm2hyqppngd4616qc96lmm9zl2kl9yl32k"))
|
||||
(patches (search-patches "gcc-arm-bug-71399.patch"
|
||||
"gcc-strmov-store-file-names.patch"
|
||||
"gcc-asan-powerpc-missing-include.patch"
|
||||
"gcc-5.0-libvtv-runpath.patch"
|
||||
"gcc-5-source-date-epoch-1.patch"
|
||||
"gcc-5-source-date-epoch-2.patch"
|
||||
|
@ -1,20 +0,0 @@
|
||||
Add missing include that triggers a build failure on PowerPC:
|
||||
|
||||
../../../../gcc-5.4.0/libsanitizer/asan/asan_linux.cc: In function ‘bool __asan::AsanInterceptsSignal(int)’:
|
||||
../../../../gcc-5.4.0/libsanitizer/asan/asan_linux.cc:222:20: error: ‘SIGSEGV’ was not declared in this scope
|
||||
return signum == SIGSEGV && common_flags()->handle_segv;
|
||||
^
|
||||
From <https://patchwork.ozlabs.org/patch/725596/>.
|
||||
|
||||
diff --git a/libsanitizer/asan/asan_linux.cc b/libsanitizer/asan/asan_linux.cc
|
||||
index c504168..59087b9 100644
|
||||
--- a/libsanitizer/asan/asan_linux.cc
|
||||
+++ b/libsanitizer/asan/asan_linux.cc
|
||||
@@ -29,6 +29,7 @@
|
||||
#include <dlfcn.h>
|
||||
#include <fcntl.h>
|
||||
#include <pthread.h>
|
||||
+#include <signal.h>
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
#include <unwind.h>
|
Loading…
Reference in New Issue
Block a user