gnu: guile-email: Update to 0.3.0.
* gnu/packages/guile-xyz.scm (guile-email): Update to 0.3.0. [native-inputs]: Remove pkg-config and lzip. Add texinfo. [arguments]: Remove GUILE_AUTO_COMPILE=0 make-flag. Add prefix make-flag. Delete configure phase. (guile2.2-email)[arguments]: Add guile_effective_version=2.2 make-flag. * gnu/packages/patches/guile-email-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Unregister it.
This commit is contained in:
parent
22ffa5e00a
commit
38086021b8
@ -1288,7 +1288,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/guile-present-coding.patch \
|
||||
%D%/packages/patches/guile-rsvg-pkgconfig.patch \
|
||||
%D%/packages/patches/guile-emacs-fix-configure.patch \
|
||||
%D%/packages/patches/guile-email-fix-tests.patch \
|
||||
%D%/packages/patches/gtk2-fix-builder-test.patch \
|
||||
%D%/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \
|
||||
%D%/packages/patches/gtk2-respect-GUIX_GTK2_IM_MODULE_FILE.patch \
|
||||
|
@ -17,7 +17,7 @@
|
||||
;;; Copyright © 2017 Nikita <nikita@n0.is>
|
||||
;;; Copyright © 2017, 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||
;;; Copyright © 2018, 2019, 2020, 2021, 2022 Arun Isaac <arunisaac@systemreboot.net>
|
||||
;;; Copyright © 2018, 2019, 2020, 2021, 2022, 2023 Arun Isaac <arunisaac@systemreboot.net>
|
||||
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
|
||||
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
|
||||
;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
|
||||
@ -1475,25 +1475,26 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
|
||||
(define-public guile-email
|
||||
(package
|
||||
(name "guile-email")
|
||||
(version "0.2.2")
|
||||
(version "0.3.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://guile-email.systemreboot.net/releases/guile-email-"
|
||||
version ".tar.lz"))
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://git.systemreboot.net/guile-email")
|
||||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1rc8r0fgvflnyq5ckl7ii8sghpsgpkzxa8vskjr1ak2kyar6m35k"))
|
||||
(patches
|
||||
(search-patches "guile-email-fix-tests.patch"))))
|
||||
"0q98r460yr75gyxg06zrrixwazncd9nxl2pgr68mff2wf41f291h"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
(list pkg-config lzip))
|
||||
(list texinfo))
|
||||
(inputs
|
||||
(list guile-3.0))
|
||||
(arguments
|
||||
'(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ; to prevent guild warnings
|
||||
(list #:make-flags #~(list (string-append "prefix=" #$output))
|
||||
#:phases #~(modify-phases %standard-phases
|
||||
(delete 'configure))))
|
||||
(home-page "https://guile-email.systemreboot.net")
|
||||
(synopsis "Guile email parser")
|
||||
(description "guile-email is a collection of email utilities implemented
|
||||
@ -1527,7 +1528,12 @@ format.")
|
||||
(inherit guile-email)
|
||||
(name "guile2.2-email")
|
||||
(inputs (modify-inputs (package-inputs guile-email)
|
||||
(replace "guile" guile-2.2)))))
|
||||
(replace "guile" guile-2.2)))
|
||||
(arguments
|
||||
(substitute-keyword-arguments (package-arguments guile-email)
|
||||
((#:make-flags make-flags '())
|
||||
#~(cons "guile_effective_version=2.2"
|
||||
#$make-flags))))))
|
||||
|
||||
(define-public guile-newra
|
||||
;; There has been no release let.
|
||||
|
@ -1,35 +0,0 @@
|
||||
This patch has been proposed upstream:
|
||||
https://lists.systemreboot.net/guile-email/87mtnv1r2p.fsf@gnu.org/T/#u.
|
||||
|
||||
From c21fe0f0e28b80b606973d3e372e2bc8528c9766 Mon Sep 17 00:00:00 2001
|
||||
From: Mathieu Othacehe <othacehe@gnu.org>
|
||||
Date: Wed, 29 Sep 2021 12:47:35 +0000
|
||||
Subject: [PATCH 1/1] email: Do not use an empty bytevector to test the
|
||||
charset.
|
||||
|
||||
Using an empty bytevector no longer throws an exception since this Guile
|
||||
commit: 5ea8c69e9153a970952bf6f0b32c4fad6a28e839.
|
||||
|
||||
* email/email.scm (post-process-content-transfer-encoding): Use a bytevector
|
||||
containg the 'e' character to test the charset validity.
|
||||
---
|
||||
email/email.scm | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/email/email.scm b/email/email.scm
|
||||
index 3f4e194..ac70463 100644
|
||||
--- a/email/email.scm
|
||||
+++ b/email/email.scm
|
||||
@@ -832,7 +832,8 @@ values. The returned headers is a string and body is a bytevector."
|
||||
(define (valid-charset? charset)
|
||||
(catch #t
|
||||
(lambda ()
|
||||
- (bytevector->string (make-bytevector 0 0) charset)
|
||||
+ ;; Try to convert a bytevector containg the 'e' character.
|
||||
+ (bytevector->string (make-bytevector 1 48) charset)
|
||||
#t)
|
||||
(const #f)))
|
||||
|
||||
--
|
||||
2.33.0
|
||||
|
Loading…
Reference in New Issue
Block a user