gnu: cyrus-sasl: Fix cross-compilation.
* gnu/packages/patches/cyrus-sasl-ac-try-run-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/cyrus-sasl.scm (cyrus-sasl)[origin]: Apply it. [native-tools]: Add autoconf, automake and libtool. [arguments]: Run autoconf to apply m4 modification in patch above.
This commit is contained in:
parent
e45c333c55
commit
3382a4f344
@ -763,6 +763,7 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/cube-nocheck.patch \
|
||||
%D%/packages/patches/cursynth-wave-rand.patch \
|
||||
%D%/packages/patches/cvs-CVE-2017-12836.patch \
|
||||
%D%/packages/patches/cyrus-sasl-ac-try-run-fix.patch \
|
||||
%D%/packages/patches/darkice-workaround-fpermissive-error.patch \
|
||||
%D%/packages/patches/dbus-helper-search-path.patch \
|
||||
%D%/packages/patches/dbus-c++-gcc-compat.patch \
|
||||
|
@ -2,6 +2,7 @@
|
||||
;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
|
||||
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
|
||||
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
@ -20,6 +21,7 @@
|
||||
|
||||
(define-module (gnu packages cyrus-sasl)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages autotools)
|
||||
#:use-module (gnu packages dbm)
|
||||
#:use-module (gnu packages kerberos)
|
||||
#:use-module (gnu packages tls)
|
||||
@ -41,8 +43,13 @@
|
||||
"ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
|
||||
version ".tar.gz")))
|
||||
(sha256 (base32
|
||||
"1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))))
|
||||
"1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))
|
||||
(patches (search-patches "cyrus-sasl-ac-try-run-fix.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("autoconf" ,autoconf)
|
||||
("automake" ,automake)
|
||||
("libtool" ,libtool)))
|
||||
(inputs `(("gdbm" ,gdbm)
|
||||
("openssl" ,openssl)))
|
||||
(propagated-inputs
|
||||
@ -57,7 +64,13 @@
|
||||
;; 'plugin_common.c'. When building the shared libraries there, libtool
|
||||
;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
|
||||
;; fail with EEXIST when building things in parallel.
|
||||
#:parallel-build? #f))
|
||||
#:parallel-build? #f
|
||||
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'unpack 'autogen
|
||||
(lambda _
|
||||
(invoke "autoreconf" "-vif"))))))
|
||||
(synopsis "Simple Authentication Security Layer implementation")
|
||||
(description
|
||||
"SASL (Simple Authentication Security Layer) is an Internet
|
||||
|
12
gnu/packages/patches/cyrus-sasl-ac-try-run-fix.patch
Normal file
12
gnu/packages/patches/cyrus-sasl-ac-try-run-fix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- a/m4/sasl2.m4 2018-11-18 22:33:29.902625600 +0300
|
||||
+++ b/m4/sasl2.m4 2018-11-18 22:33:59.828746176 +0300
|
||||
@@ -339,7 +339,8 @@
|
||||
],
|
||||
[ AC_DEFINE(HAVE_GSS_SPNEGO,,[Define if your GSSAPI implementation supports SPNEGO])
|
||||
AC_MSG_RESULT(yes) ],
|
||||
- AC_MSG_RESULT(no))
|
||||
+ AC_MSG_RESULT(no),
|
||||
+ AC_MSG_RESULT(no))
|
||||
LIBS="$cmu_save_LIBS"
|
||||
|
||||
else
|
Loading…
Reference in New Issue
Block a user