gnu: wgetpaste: Update bpaste URL & regular expressions.
* gnu/packages/wget.scm (wgetpaste)[source]: Add patch. * gnu/packages/patches/wgetpaste-update-bpaste.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
7b88396feb
commit
30714da09a
@ -1656,6 +1656,7 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/webkitgtk-share-store.patch \
|
||||
%D%/packages/patches/webkitgtk-bind-all-fonts.patch \
|
||||
%D%/packages/patches/websocketpp-fix-for-cmake-3.15.patch \
|
||||
%D%/packages/patches/wgetpaste-update-bpaste.patch \
|
||||
%D%/packages/patches/wicd-bitrate-none-fix.patch \
|
||||
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
|
||||
%D%/packages/patches/wicd-urwid-1.3.patch \
|
||||
|
27
gnu/packages/patches/wgetpaste-update-bpaste.patch
Normal file
27
gnu/packages/patches/wgetpaste-update-bpaste.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Tue, 01 Sep 2020 04:23:25 +0200
|
||||
Subject: [PATCH] Update bpaste URL & regular expressions.
|
||||
|
||||
diff -Naur wgetpaste-2.30/wgetpaste wgetpaste-2.30a/wgetpaste
|
||||
--- wgetpaste-2.30/wgetpaste 2020-07-31 23:56:05.000000000 +0200
|
||||
+++ wgetpaste-2.30a/wgetpaste 2020-09-01 04:22:37.499898403 +0200
|
||||
@@ -16,7 +16,7 @@
|
||||
SERVICES="codepad bpaste dpaste gists snippets"
|
||||
# bpaste
|
||||
ENGINE_bpaste=pinnwand
|
||||
-URL_bpaste="https://bpaste.net/"
|
||||
+URL_bpaste="https://bpa.st/"
|
||||
DEFAULT_EXPIRATION_bpaste="1week"
|
||||
DEFAULT_LANGUAGE_bpaste="text"
|
||||
# codepad
|
||||
@@ -194,8 +194,8 @@
|
||||
xml+velocity xml xquery xslt xtend yaml"
|
||||
EXPIRATIONS_pinnwand="1day 1week 1month never"
|
||||
POST_pinnwand="submit=Paste! % % lexer expiry % code"
|
||||
-REGEX_LOC_pinnwand="\(/show/[^ ]*\).*$|https://bpaste.net\1"
|
||||
-REGEX_RAW_pinnwand='s|^\(https\?://[^/]*/\)show\(/[^ ]*/\?\)$|\1raw\2|'
|
||||
+REGEX_LOC_pinnwand="\(/[^ ]*\).*$|https://bpa.st\1"
|
||||
+REGEX_RAW_pinnwand='s|^\(https\?://[^/]*\)\(/[^ ]*/\?\)$|\1/raw\2|'
|
||||
|
||||
### errors
|
||||
die() {
|
@ -83,7 +83,8 @@ in downloaded documents to relative links.")
|
||||
(uri (string-append "https://wgetpaste.zlin.dk/wgetpaste-"
|
||||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32 "14k5i6j6f34hcf9gdb9cnvfwscn0ys2dgd73ci421wj9zzqkbv73"))))
|
||||
(base32 "14k5i6j6f34hcf9gdb9cnvfwscn0ys2dgd73ci421wj9zzqkbv73"))
|
||||
(patches (search-patches "wgetpaste-update-bpaste.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:modules ((guix build gnu-build-system)
|
||||
|
Loading…
Reference in New Issue
Block a user