gnu: weex: Update to 2.8.2 [fixes CVE-2005-3150].
* gnu/packages/ftp.scm (weex): Update to 2.8.2. [source]: Use new URL. Remove obsolete 'weex-vacopy.patch'. [arguments]: Remove custom 'configure' phase and add 'bootstrap' phase. [native-inputs]: Add autoconf, automake, and gnu-gettext. * gnu/packages/patches/weex-vacopy.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
268b3802e9
commit
2d125a9b21
@ -892,7 +892,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
|
||||
%D%/packages/patches/vtk-mesa-10.patch \
|
||||
%D%/packages/patches/weechat-python.patch \
|
||||
%D%/packages/patches/weex-vacopy.patch \
|
||||
%D%/packages/patches/wicd-bitrate-none-fix.patch \
|
||||
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
|
||||
%D%/packages/patches/wicd-urwid-1.3.patch \
|
||||
|
@ -25,6 +25,8 @@
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix packages)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages autotools)
|
||||
#:use-module (gnu packages gettext)
|
||||
#:use-module (gnu packages ncurses)
|
||||
#:use-module (gnu packages readline)
|
||||
#:use-module (gnu packages pkg-config)
|
||||
@ -126,31 +128,26 @@ FTP browser, as well as non-interactive commands such as 'ncftpput' and
|
||||
(define-public weex
|
||||
(package
|
||||
(name "weex")
|
||||
(version "2.6.1.5")
|
||||
(version "2.8.2")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri
|
||||
(string-append "mirror://sourceforge/weex/weex/" version
|
||||
"/weex-" version ".tar.gz"))
|
||||
(string-append "mirror://sourceforge/weex/weex/"
|
||||
"/weex_" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0f5cj5p852wkm24mzy2sxgxyahv2p9rk4wlq21j310pi7wlhgwyl"))
|
||||
(patches (search-patches "weex-vacopy.patch"))))
|
||||
"1ir761hjncr1bamaqcw9j7x57xi3s9jax3223bxwbq30a0vsw1pd"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("automake" ,automake)
|
||||
("autoconf" ,autoconf)
|
||||
("gettext" ,gnu-gettext)))
|
||||
(arguments
|
||||
`(#:phases
|
||||
(modify-phases %standard-phases
|
||||
(replace 'configure
|
||||
;; configure does not work followed by both "SHELL=..." and
|
||||
;; "CONFIG_SHELL=..."; set environment variables instead
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(let* ((out (assoc-ref outputs "out"))
|
||||
(bash (which "bash")))
|
||||
(setenv "SHELL" bash)
|
||||
(setenv "CONFIG_SHELL" bash)
|
||||
(zero? (system* bash "./configure"
|
||||
(string-append "--prefix=" out)))))))))
|
||||
(add-before 'configure 'bootstrap
|
||||
(lambda _ (zero? (system* "autoreconf" "-vfi")))))))
|
||||
(home-page "http://weex.sourceforge.net/")
|
||||
(synopsis "Non-interactive client for FTP synchronization")
|
||||
(description
|
||||
|
@ -1,13 +0,0 @@
|
||||
Taken from the Debian 2.8.0 package.
|
||||
|
||||
--- weex-2.6.1.5/src/strlib.c 2003-08-18 11:52:38.000000000 +0200
|
||||
+++ weex-2.8.0/src/strlib.c 2007-12-04 14:22:02.000000000 +0100
|
||||
@@ -42,6 +42,8 @@
|
||||
# define G_VA_COPY(ap1, ap2) (*(ap1) = *(ap2))
|
||||
# elif defined (G_VA_COPY_AS_ARRAY)
|
||||
# define G_VA_COPY(ap1, ap2) g_memmove ((ap1), (ap2), sizeof (va_list))
|
||||
+# elif defined (__x86_64__)
|
||||
+# define G_VA_COPY(ap1, ap2) memmove ((ap1), (ap2), sizeof (va_list))
|
||||
# else /* va_list is a pointer */
|
||||
# define G_VA_COPY(ap1, ap2) ((ap1) = (ap2))
|
||||
# endif /* va_list is a pointer */
|
Loading…
Reference in New Issue
Block a user