gnu: Update llvm-for-rocm: Update to 5.1.3.
* gnu/packages/llvm.scm (llvm-for-rocm): Update to 5.1.3, now based on llvm-14. [source]{patches}: Remove unneeded patches (add_Object and add_libraries) and add new one (linkdl). * gnu/packages/patches/llvm-roc-3.0.0-add_libraries.patch, gnu/packages/patches/llvm-roc-4.2.0-add_Object.patch: Delete files. * gnu/packages/patches/llvm-roc-5.0.0-linkdl.patch: New file. * gnu/local.mk (dist_patch_DATA): Update to match current patches. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
677ae314f6
commit
25809f5a40
@ -1452,9 +1452,8 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/llvm-9-fix-bitcast-miscompilation.patch \
|
%D%/packages/patches/llvm-9-fix-bitcast-miscompilation.patch \
|
||||||
%D%/packages/patches/llvm-9-fix-lpad-miscompilation.patch \
|
%D%/packages/patches/llvm-9-fix-lpad-miscompilation.patch \
|
||||||
%D%/packages/patches/llvm-9-fix-scev-miscompilation.patch \
|
%D%/packages/patches/llvm-9-fix-scev-miscompilation.patch \
|
||||||
%D%/packages/patches/llvm-roc-3.0.0-add_libraries.patch \
|
|
||||||
%D%/packages/patches/llvm-roc-4.0.0-remove-isystem-usr-include.patch \
|
%D%/packages/patches/llvm-roc-4.0.0-remove-isystem-usr-include.patch \
|
||||||
%D%/packages/patches/llvm-roc-4.2.0-add_Object.patch \
|
%D%/packages/patches/llvm-roc-5.0.0-linkdl.patch \
|
||||||
%D%/packages/patches/lm-sensors-hwmon-attrs.patch \
|
%D%/packages/patches/lm-sensors-hwmon-attrs.patch \
|
||||||
%D%/packages/patches/lrcalc-includes.patch \
|
%D%/packages/patches/lrcalc-includes.patch \
|
||||||
%D%/packages/patches/lsh-fix-x11-forwarding.patch \
|
%D%/packages/patches/lsh-fix-x11-forwarding.patch \
|
||||||
|
@ -23,6 +23,7 @@
|
|||||||
;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
|
;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
|
||||||
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
||||||
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
|
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
|
||||||
|
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
|
||||||
;;;
|
;;;
|
||||||
;;; This file is part of GNU Guix.
|
;;; This file is part of GNU Guix.
|
||||||
;;;
|
;;;
|
||||||
@ -1109,10 +1110,10 @@ of programming tools as well as libraries with equivalent functionality.")
|
|||||||
|
|
||||||
(define-public llvm-for-rocm
|
(define-public llvm-for-rocm
|
||||||
(package
|
(package
|
||||||
;; Actually based on LLVM 13 as of v4.3, but llvm-12 works just fine.
|
;; Based on LLVM 14 as of v5.0.0
|
||||||
(inherit llvm-12)
|
(inherit llvm-14)
|
||||||
(name "llvm-for-rocm")
|
(name "llvm-for-rocm")
|
||||||
(version "4.3.0") ;this must match '%rocm-version'
|
(version "5.1.3") ;this must match '%rocm-version'
|
||||||
(source (origin
|
(source (origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
(uri (git-reference
|
(uri (git-reference
|
||||||
@ -1121,10 +1122,9 @@ of programming tools as well as libraries with equivalent functionality.")
|
|||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0p75nr1qpmy6crymdax5hm40wkimman4lnglz4x5cnbiqindya7s"))
|
"0j6ydfkwrxwskgnhxc3cmry42n5faqbnwf2747qgf7lz5id8h8g5"))
|
||||||
(patches
|
(patches
|
||||||
(search-patches "llvm-roc-4.2.0-add_Object.patch"
|
(search-patches "llvm-roc-5.0.0-linkdl.patch"
|
||||||
"llvm-roc-3.0.0-add_libraries.patch"
|
|
||||||
"llvm-roc-4.0.0-remove-isystem-usr-include.patch"))))
|
"llvm-roc-4.0.0-remove-isystem-usr-include.patch"))))
|
||||||
(arguments
|
(arguments
|
||||||
(substitute-keyword-arguments (package-arguments llvm-12)
|
(substitute-keyword-arguments (package-arguments llvm-12)
|
||||||
@ -1141,7 +1141,7 @@ of programming tools as well as libraries with equivalent functionality.")
|
|||||||
"-DBUILD_SHARED_LIBS:BOOL=TRUE"
|
"-DBUILD_SHARED_LIBS:BOOL=TRUE"
|
||||||
"-DLLVM_VERSION_SUFFIX="))))
|
"-DLLVM_VERSION_SUFFIX="))))
|
||||||
(properties `((hidden? . #t)
|
(properties `((hidden? . #t)
|
||||||
,@(package-properties llvm-12)))))
|
,@(package-properties llvm-14)))))
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
@ -1,22 +0,0 @@
|
|||||||
Taken from https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-devel/llvm-roc/files
|
|
||||||
|
|
||||||
diff -Naur a/clang/lib/Basic/CMakeLists.txt b/clang/lib/Basic/CMakeLists.txt
|
|
||||||
--- a/clang/lib/Basic/CMakeLists.txt 2019-12-28 07:42:49.119055933 +0100
|
|
||||||
+++ b/clang/lib/Basic/CMakeLists.txt 2019-12-28 07:42:13.265056070 +0100
|
|
||||||
@@ -2,6 +2,7 @@
|
|
||||||
Core
|
|
||||||
MC
|
|
||||||
Support
|
|
||||||
+ Option
|
|
||||||
)
|
|
||||||
|
|
||||||
find_first_existing_vc_file("${LLVM_MAIN_SRC_DIR}" llvm_vc)
|
|
||||||
diff -Naur a/clang/lib/Driver/CMakeLists.txt b/clang/lib/Driver/CMakeLists.txt
|
|
||||||
--- a/clang/lib/Driver/CMakeLists.txt 2019-12-28 07:41:39.521056199 +0100
|
|
||||||
+++ b/clang/lib/Driver/CMakeLists.txt 2019-12-28 07:40:23.998056487 +0100
|
|
||||||
@@ -79,4 +79,5 @@
|
|
||||||
LINK_LIBS
|
|
||||||
clangBasic
|
|
||||||
${system_libs}
|
|
||||||
+ pthread
|
|
||||||
)
|
|
@ -1,13 +0,0 @@
|
|||||||
Taken from https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-devel/llvm-roc/files
|
|
||||||
|
|
||||||
diff --color -uprN orig/lib/Target/AMDGPU/Disassembler/CMakeLists.txt llvm/lib/Target/AMDGPU/Disassembler/CMakeLists.txt
|
|
||||||
--- a/llvm/lib/Target/AMDGPU/Disassembler/CMakeLists.txt 2021-06-14 11:57:54.222796911 +0800
|
|
||||||
+++ b/llvm/lib/Target/AMDGPU/Disassembler/CMakeLists.txt 2021-06-14 11:58:35.206796875 +0800
|
|
||||||
@@ -11,6 +11,7 @@ add_llvm_component_library(LLVMAMDGPUDis
|
|
||||||
MC
|
|
||||||
MCDisassembler
|
|
||||||
Support
|
|
||||||
+ Object
|
|
||||||
|
|
||||||
ADD_TO_COMPONENT
|
|
||||||
AMDGPU
|
|
15
gnu/packages/patches/llvm-roc-5.0.0-linkdl.patch
Normal file
15
gnu/packages/patches/llvm-roc-5.0.0-linkdl.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
Taken from the Gentoo patch:
|
||||||
|
https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-devel/llvm-roc/files/llvm-roc-5.0.0-linkdl.patch
|
||||||
|
|
||||||
|
LLVMOffloadArch should link libdl to fix undefined symbol 'dlsym' when linking
|
||||||
|
|
||||||
|
--- a/llvm/lib/OffloadArch/offload-arch/CMakeLists.txt
|
||||||
|
+++ b/llvm/lib/OffloadArch/offload-arch/CMakeLists.txt
|
||||||
|
@@ -3,6 +3,7 @@ add_llvm_tool(offload-arch
|
||||||
|
${CMAKE_CURRENT_SOURCE_DIR}/offload-arch.cpp
|
||||||
|
DEPENDS generated-table LLVMOffloadArch
|
||||||
|
)
|
||||||
|
+target_link_libraries(LLVMOffloadArch PRIVATE ${CMAKE_DL_LIBS})
|
||||||
|
target_link_libraries(offload-arch PRIVATE LLVMOffloadArch)
|
||||||
|
|
||||||
|
if(CMAKE_HOST_UNIX)
|
Loading…
Reference in New Issue
Block a user