gnu: nftables: Update to 1.0.2.

* gnu/packages/patches/nftables-fix-makefile.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/linux.scm (nftables): Update to 1.0.2.
[source]: Add patch.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
kiasoc5 2022-04-28 16:41:10 -04:00 committed by Ludovic Courtès
parent 9e630a362d
commit 253fc14777
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 52 additions and 4 deletions

View File

@ -1527,6 +1527,7 @@ dist_patch_DATA = \
%D%/packages/patches/netsurf-system-utf8proc.patch \ %D%/packages/patches/netsurf-system-utf8proc.patch \
%D%/packages/patches/netsurf-y2038-tests.patch \ %D%/packages/patches/netsurf-y2038-tests.patch \
%D%/packages/patches/netsurf-longer-test-timeout.patch \ %D%/packages/patches/netsurf-longer-test-timeout.patch \
%D%/packages/patches/nftables-fix-makefile.patch \
%D%/packages/patches/nhc98-c-update.patch \ %D%/packages/patches/nhc98-c-update.patch \
%D%/packages/patches/nix-dont-build-html-doc.diff \ %D%/packages/patches/nix-dont-build-html-doc.diff \
%D%/packages/patches/nfs4-acl-tools-0.3.7-fixpaths.patch \ %D%/packages/patches/nfs4-acl-tools-0.3.7-fixpaths.patch \

View File

@ -7238,7 +7238,7 @@ used by nftables.")
(define-public nftables (define-public nftables
(package (package
(name "nftables") (name "nftables")
(version "1.0.1") (version "1.0.2")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -7247,14 +7247,27 @@ used by nftables.")
(string-append "https://www.nftables.org/projects/nftables" (string-append "https://www.nftables.org/projects/nftables"
"/files/nftables-" version ".tar.bz2"))) "/files/nftables-" version ".tar.bz2")))
(sha256 (sha256
(base32 "08x4xw0s5sap3q7jfr91v7mrkxrydi4dvsckw85ims0qb1ibmviw")))) (base32 "00jcjn1pl7qyqpg8pd4yhlkys7wbj4vkzgg73n27nmplzips6a0b"))
(patches
(search-patches "nftables-fix-makefile.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments `(#:configure-flags (arguments `(#:configure-flags
'("--disable-static" '("--disable-static"
"--with-cli=readline" "--with-cli=readline"
"--with-json"))) "--with-json")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'autoreconf
(lambda _
(invoke "autoreconf" "-fi"))))))
(inputs (list gmp libmnl libnftnl readline jansson)) (inputs (list gmp libmnl libnftnl readline jansson))
(native-inputs (list pkg-config bison flex docbook2x)) (native-inputs (list pkg-config
bison
flex
docbook2x
autoconf
automake
libtool))
(home-page "https://www.nftables.org") (home-page "https://www.nftables.org")
(synopsis "Userspace utility for Linux packet filtering") (synopsis "Userspace utility for Linux packet filtering")
(description "nftables is the project that aims to replace the existing (description "nftables is the project that aims to replace the existing

View File

@ -0,0 +1,34 @@
From 18a08fb7f0443f8bde83393bd6f69e23a04246b3 Mon Sep 17 00:00:00 2001
From: Pablo Neira Ayuso <pablo@netfilter.org>
Date: Tue, 22 Feb 2022 00:56:36 +0100
Subject: examples: compile with `make check' and add AM_CPPFLAGS
Compile examples via `make check' like libnftnl does. Use AM_CPPFLAGS to
specify local headers via -I.
Unfortunately, `make distcheck' did not catch this compile time error in
my system, since it was using the nftables/libnftables.h file of the
previous nftables release.
Fixes: 5b364657a35f ("build: missing SUBIRS update")
Fixes: caf2a6ad2d22 ("examples: add libnftables example program")
Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
---
examples/Makefile.am | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/examples/Makefile.am b/examples/Makefile.am
index c972170d..3b8b0b67 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,4 +1,6 @@
-noinst_PROGRAMS = nft-buffer \
+check_PROGRAMS = nft-buffer \
nft-json-file
+AM_CPPFLAGS = -I$(top_srcdir)/include
+
LDADD = $(top_builddir)/src/libnftables.la
--
cgit v1.2.3