gnu: ghostscript: Update to 9.54.0.
* gnu/packages/patches/ghostscript-freetype-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/ghostscript.scm (ghostscript): Update to 9.54.0. [source](patches): Remove obsolete patch.
This commit is contained in:
parent
911668ab4c
commit
23666a9b62
@ -1083,7 +1083,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/ghc-monad-par-fix-tests.patch \
|
||||
%D%/packages/patches/ghc-pandoc-fix-html-tests.patch \
|
||||
%D%/packages/patches/ghc-pandoc-fix-latex-test.patch \
|
||||
%D%/packages/patches/ghostscript-freetype-compat.patch \
|
||||
%D%/packages/patches/ghostscript-no-header-id.patch \
|
||||
%D%/packages/patches/ghostscript-no-header-uuid.patch \
|
||||
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
|
||||
|
@ -159,7 +159,7 @@ printing, and psresize, for adjusting page sizes.")
|
||||
(define-public ghostscript
|
||||
(package
|
||||
(name "ghostscript")
|
||||
(version "9.53.3")
|
||||
(version "9.54.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
@ -169,9 +169,8 @@ printing, and psresize, for adjusting page sizes.")
|
||||
"/ghostscript-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0d52w9ajv1rz533119ywgmkzkapp74riwny0d21v0zkcbg45p7ww"))
|
||||
(patches (search-patches "ghostscript-freetype-compat.patch"
|
||||
"ghostscript-no-header-creationdate.patch"
|
||||
"0fvfvv6di5s6j4sy4gaw65klm23dby39bkdjxxq4w3v0vqyb9dy2"))
|
||||
(patches (search-patches "ghostscript-no-header-creationdate.patch"
|
||||
"ghostscript-no-header-id.patch"
|
||||
"ghostscript-no-header-uuid.patch"))
|
||||
(modules '((guix build utils)))
|
||||
|
@ -1,35 +0,0 @@
|
||||
Fix build with FreeType 2.10.3 and newer.
|
||||
|
||||
Taken from upstream:
|
||||
https://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=41ef9a0bc36b9db7115fbe9623f989bfb47bbade
|
||||
|
||||
diff --git a/base/fapi_ft.c b/base/fapi_ft.c
|
||||
--- a/base/fapi_ft.c
|
||||
+++ b/base/fapi_ft.c
|
||||
@@ -125,7 +125,7 @@ static void
|
||||
delete_inc_int_info(gs_fapi_server * a_server,
|
||||
FT_IncrementalRec * a_inc_int_info);
|
||||
|
||||
-FT_CALLBACK_DEF(void *)
|
||||
+static void *
|
||||
FF_alloc(FT_Memory memory, long size)
|
||||
{
|
||||
gs_memory_t *mem = (gs_memory_t *) memory->user;
|
||||
@@ -133,7 +133,7 @@ FF_alloc(FT_Memory memory, long size)
|
||||
return (gs_malloc(mem, size, 1, "FF_alloc"));
|
||||
}
|
||||
|
||||
-FT_CALLBACK_DEF(void *)
|
||||
+static void *
|
||||
FF_realloc(FT_Memory memory, long cur_size, long new_size, void *block)
|
||||
{
|
||||
gs_memory_t *mem = (gs_memory_t *) memory->user;
|
||||
@@ -153,7 +153,7 @@ FT_CALLBACK_DEF(void *)
|
||||
return (tmp);
|
||||
}
|
||||
|
||||
-FT_CALLBACK_DEF(void)
|
||||
+static void
|
||||
FF_free(FT_Memory memory, void *block)
|
||||
{
|
||||
gs_memory_t *mem = (gs_memory_t *) memory->user;
|
Loading…
Reference in New Issue
Block a user