gnu: date: Fix build with newer tzdata.

* gnu/packages/patches/date-ignore-zonenow.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/calendar.scm (date): Use it.

Change-Id: I29bdfb49237650706abd870f2b9875739d12c6d5
This commit is contained in:
Josselin Poiret 2024-03-08 13:06:12 +01:00 committed by Ludovic Courtès
parent 378ee3183a
commit 2008a30d4c
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 16 additions and 1 deletions

View File

@ -1115,6 +1115,7 @@ dist_patch_DATA = \
%D%/packages/patches/cvs-CVE-2017-12836.patch \
%D%/packages/patches/d-feet-drop-unused-meson-argument.patch \
%D%/packages/patches/dante-non-darwin.patch \
%D%/packages/patches/date-ignore-zonenow.patch \
%D%/packages/patches/date-output-pkg-config-files.patch \
%D%/packages/patches/datefudge-gettimeofday.patch \
%D%/packages/patches/dbacl-include-locale.h.patch \

View File

@ -85,7 +85,8 @@
(patches
;; Install pkg-config files
;; https://github.com/HowardHinnant/date/pull/538
(search-patches "date-output-pkg-config-files.patch"))))
(search-patches "date-ignore-zonenow.patch"
"date-output-pkg-config-files.patch"))))
(inputs (list tzdata))
(build-system cmake-build-system)
(arguments

View File

@ -0,0 +1,13 @@
Ignore the new zonenow.tab file introduced in tzdata 2023d.
diff -u a/src/tz.cpp b/src/tz.cpp
--- a/src/tz.cpp 2024-03-08 11:14:14.822488065 +0100
+++ b/src/tz.cpp 2024-03-08 11:47:12.105268426 +0100
@@ -2667,6 +2667,7 @@
strcmp(d->d_name, "right") == 0 ||
strcmp(d->d_name, "+VERSION") == 0 ||
strcmp(d->d_name, "zone.tab") == 0 ||
+ strcmp(d->d_name, "zonenow.tab") == 0 ||
strcmp(d->d_name, "zone1970.tab") == 0 ||
strcmp(d->d_name, "tzdata.zi") == 0 ||
strcmp(d->d_name, "leapseconds") == 0 ||