gnu: Add python-pyreadstat.
* gnu/packages/patches/python-pyreadstat-link-libiconv.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/statistics.scm (python-pyreadstat): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Change-Id: I361df91487412e4bfd26fb728a6999752e6343e5
This commit is contained in:
parent
76470d47c5
commit
185ebc01f6
@ -62,6 +62,7 @@
|
||||
# Copyright © 2023 B. Wilson <elaexuotee@wilsonb.com>
|
||||
# Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
|
||||
# Copyright © 2023 Herman Rimm <herman@rimm.ee>
|
||||
# Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
|
||||
#
|
||||
# This file is part of GNU Guix.
|
||||
#
|
||||
@ -1777,6 +1778,7 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/python-louvain-fix-test.patch \
|
||||
%D%/packages/patches/python-random2-getrandbits-test.patch \
|
||||
%D%/packages/patches/python-poppler-qt5-fix-build.patch \
|
||||
%D%/packages/patches/python-pyreadstat-link-libiconv.patch \
|
||||
%D%/packages/patches/python-pypdf-annotate-tests-appropriately.patch \
|
||||
%D%/packages/patches/python-pytorch2-system-libraries.patch \
|
||||
%D%/packages/patches/python-sip-include-dirs.patch \
|
||||
|
15
gnu/packages/patches/python-pyreadstat-link-libiconv.patch
Normal file
15
gnu/packages/patches/python-pyreadstat-link-libiconv.patch
Normal file
@ -0,0 +1,15 @@
|
||||
To ensure libiconv can be found by Guix, we need to link the library.
|
||||
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -81,8 +81,7 @@ else:
|
||||
libraries.extend(["m", "z"])
|
||||
_platform = sys.platform
|
||||
# Mac: iconv needs to be linked statically
|
||||
- if _platform.lower().startswith("darwin"):
|
||||
- libraries.append("iconv")
|
||||
+ libraries.append("iconv")
|
||||
|
||||
# Extensions
|
||||
sources.sort()
|
||||
|
@ -18,6 +18,7 @@
|
||||
;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
|
||||
;;; Copyright © 2022 Simon Tournier <zimon.toutoune@gmail.com>
|
||||
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
|
||||
;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
@ -6919,6 +6920,50 @@ files, including Rmarkdown files.")
|
||||
popular stats packages like SAS, Stata and SPSS.")
|
||||
(license license:expat)))
|
||||
|
||||
(define-public python-pyreadstat
|
||||
(package
|
||||
(name "python-pyreadstat")
|
||||
(version "1.2.4")
|
||||
;; No tests in the PyPI tarball.
|
||||
(source
|
||||
(origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/Roche/pyreadstat")
|
||||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0zysrzixvqw2lwwykxqg5yj8a0zyv5s2bmk22x30f4rj2hgvq1pv"))
|
||||
(patches (search-patches "python-pyreadstat-link-libiconv.patch"))))
|
||||
(arguments
|
||||
'(#:phases (modify-phases %standard-phases
|
||||
(add-before 'check 'change-home-dir
|
||||
(lambda _
|
||||
;; test_sav_expand and test_sav_write_basic_expanduser need a
|
||||
;; home directory with write permissions.
|
||||
(setenv "HOME" "/tmp")))
|
||||
(replace 'check
|
||||
(lambda* (#:key tests? #:allow-other-keys)
|
||||
(when tests?
|
||||
;; The source also contains tests/test_version.py
|
||||
;; which checks the version in __init__.py against the
|
||||
;; one in setup.py. Since this requires texlive
|
||||
;; dependencies to run and is also not mentioned in
|
||||
;; how_to_test.md, this test is skipped.
|
||||
(invoke "python" "tests/test_basic.py")))))))
|
||||
(build-system python-build-system)
|
||||
(propagated-inputs (list python-pandas))
|
||||
(inputs (list libiconv zlib))
|
||||
(native-inputs (list python-cython-3))
|
||||
(home-page "https://github.com/Roche/pyreadstat")
|
||||
(synopsis
|
||||
"Read and write SAS, SPSS and Stata files into/from Pandas DataFrames")
|
||||
(description
|
||||
"This Python package can be used to read and write SAS, SPSS and Stata
|
||||
files into/from Pandas DataFrames. It is a wrapper around the C library
|
||||
@code{readstat}.")
|
||||
(license license:asl2.0)))
|
||||
|
||||
(define-public r-quantpsyc
|
||||
(package
|
||||
(name "r-quantpsyc")
|
||||
|
Loading…
Reference in New Issue
Block a user