gnu: mailutils: Update to 3.13.

* gnu/packages/patches/mailutils-fix-uninitialized-variable.patch: Remove
patch.
* gnu/local.mk (dist_patch_DATA): De-register it.
* gnu/packages/mail.scm (mailutils): Update to 3.13.  Remove the 2013
--with-sql option TODO comment; if someone needs that, they can send a patch.
[source]: Remove above patch.
[phases]{prepare-test-suite}: Also patch shell shebang in
'libmailutils/tests/lock.at' and 'imap4d/tests/testclient.c'.
[parallel-tests?]: Reinstate parallel tests.
[inputs]: Move m4 to...
[native-inputs]: ... here.  Add the autoconf, automake, gettext and libtool
quartet.
This commit is contained in:
Maxim Cournoyer 2021-09-09 13:38:53 -04:00
parent d8a184f086
commit 173b6f6f15
No known key found for this signature in database
GPG Key ID: 1260E46482E63562
3 changed files with 19 additions and 43 deletions

View File

@ -1433,7 +1433,6 @@ dist_patch_DATA = \
%D%/packages/patches/luajit-no_ldconfig.patch \
%D%/packages/patches/luit-posix.patch \
%D%/packages/patches/lvm2-static-link.patch \
%D%/packages/patches/mailutils-fix-uninitialized-variable.patch \
%D%/packages/patches/mailutils-variable-lookup.patch \
%D%/packages/patches/make-impure-dirs.patch \
%D%/packages/patches/marble-qt-add-qt-headers.patch \

View File

@ -260,18 +260,16 @@ example, modify the message headers or body, or encrypt or sign the message.")
(define-public mailutils
(package
(name "mailutils")
(version "3.10")
(version "3.13")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/mailutils/mailutils-"
version ".tar.xz"))
(sha256
(base32
"17smrxjdgbbzbzakik30vj46q4iib85ksqhb82jr4vjp57akszh9"))
"1iwl82d6aa2acsdxbqh1s5xx44sg83b4yxqik408m1s9rcfrf86r"))
(patches
;; Fixes https://issues.guix.gnu.org/43088.
(search-patches "mailutils-fix-uninitialized-variable.patch"
"mailutils-variable-lookup.patch"))))
(search-patches "mailutils-variable-lookup.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@ -295,8 +293,9 @@ example, modify the message headers or body, or encrypt or sign the message.")
;; The 'pipeact.at' tests generate a shell script; make
;; sure it uses the right shell.
(substitute* '("sieve/tests/testsuite"
"mh/tests/testsuite")
(("#! /bin/sh")
"mh/tests/testsuite"
"libmailutils/tests/lock.at")
(("#! ?/bin/sh")
(string-append "#!" (which "sh"))))
(substitute* "mh/tests/testsuite"
@ -328,8 +327,9 @@ example, modify the message headers or body, or encrypt or sign the message.")
(format port "Path: ~a/Mail-for-tests~%"
(getcwd))))
#t)))
;; TODO: Add `--with-sql'.
(substitute* "imap4d/tests/testclient.c"
(("\"/bin/sh\"")
(string-append "\"" (which "sh") "\""))))))
#:configure-flags
(list "--sysconfdir=/etc"
@ -341,16 +341,20 @@ example, modify the message headers or body, or encrypt or sign the message.")
(package-inputs this-package))
(("guile" guile)
(version-major+minor
(package-version guile))))))
#:parallel-tests? #f))
(package-version guile))))))))
(native-inputs
`(("perl" ,perl) ;for 'gylwrap'
;; Regeneration of the build system is triggered by touching the
;; 'libmailutils/tests/lock.at' file.
`(("autoconf" ,autoconf)
("automake" ,automake)
("gettext" ,gettext-minimal)
("libtool" ,libtool)
("m4" ,m4)
("perl" ,perl) ;for 'gylwrap'
("texinfo" ,texinfo)
("dejagnu" ,dejagnu)))
(inputs
`(("m4" ,m4)
("guile" ,guile-3.0)
`(("guile" ,guile-3.0)
("gsasl" ,gsasl)
("gnutls" ,gnutls)
("ncurses" ,ncurses)
@ -358,7 +362,6 @@ example, modify the message headers or body, or encrypt or sign the message.")
("linux-pam" ,linux-pam)
("libltdl" ,libltdl)
("gdbm" ,gdbm)
;; Required for SEARCH CHARSET.
("libiconv" ,libiconv)
("libunistring" ,libunistring)))

View File

@ -1,26 +0,0 @@
From 5ca6382fe8adb5bc436a6d873c8b86c69d5abfd1 Mon Sep 17 00:00:00 2001
From: Sergey Poznyakoff <gray@gnu.org>
Date: Sun, 13 Sep 2020 14:43:46 +0300
Subject: [PATCH] Fix uninitialized variable in readmsg
* readmsg/readmsg.c (main): Initialize weedc.
---
readmsg/readmsg.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/readmsg/readmsg.c b/readmsg/readmsg.c
index 9f305bb9c..3a9f420db 100644
--- a/readmsg/readmsg.c
+++ b/readmsg/readmsg.c
@@ -466,7 +466,7 @@ main (int argc, char **argv)
mu_mailbox_t mbox = NULL;
struct mu_wordsplit ws;
char **weedv;
- int weedc;
+ int weedc = 0;
int unix_header = 0;
/* Native Language Support */
--
2.28.0