gnu: mesa-opencl, mesa-opencl-icd: Build all the LLVM targets again.
Reported by John Kehayias <john.kehayias@protonmail.com> in <https://issues.guix.gnu.org/49794>. * gnu/packages/patches/mesa-opencl-all-targets.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gl.scm (mesa-opencl)[source]: Use it.
This commit is contained in:
parent
2b6bf23c60
commit
1685128e6e
@ -1414,6 +1414,7 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/libmemcached-build-with-gcc7.patch \
|
%D%/packages/patches/libmemcached-build-with-gcc7.patch \
|
||||||
%D%/packages/patches/libmhash-hmac-fix-uaf.patch \
|
%D%/packages/patches/libmhash-hmac-fix-uaf.patch \
|
||||||
%D%/packages/patches/mercurial-hg-extension-path.patch \
|
%D%/packages/patches/mercurial-hg-extension-path.patch \
|
||||||
|
%D%/packages/patches/mesa-opencl-all-targets.patch \
|
||||||
%D%/packages/patches/mesa-skip-tests.patch \
|
%D%/packages/patches/mesa-skip-tests.patch \
|
||||||
%D%/packages/patches/mescc-tools-boot.patch \
|
%D%/packages/patches/mescc-tools-boot.patch \
|
||||||
%D%/packages/patches/metabat-fix-compilation.patch \
|
%D%/packages/patches/metabat-fix-compilation.patch \
|
||||||
|
@ -471,6 +471,10 @@ from software emulation to complete hardware acceleration for modern GPUs.")
|
|||||||
(define-public mesa-opencl
|
(define-public mesa-opencl
|
||||||
(package/inherit mesa
|
(package/inherit mesa
|
||||||
(name "mesa-opencl")
|
(name "mesa-opencl")
|
||||||
|
(source (origin
|
||||||
|
(inherit (package-source mesa))
|
||||||
|
(patches (cons (search-patch "mesa-opencl-all-targets.patch")
|
||||||
|
(origin-patches (package-source mesa))))))
|
||||||
(arguments
|
(arguments
|
||||||
(substitute-keyword-arguments (package-arguments mesa)
|
(substitute-keyword-arguments (package-arguments mesa)
|
||||||
((#:configure-flags flags)
|
((#:configure-flags flags)
|
||||||
|
25
gnu/packages/patches/mesa-opencl-all-targets.patch
Normal file
25
gnu/packages/patches/mesa-opencl-all-targets.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
This patch restores LLVM targets needed for OpenCL, *reverting* this
|
||||||
|
upstream commit:
|
||||||
|
|
||||||
|
From 80817b6e344258ac9b955f824ebf9019a0fc1610 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jesse Natalie <jenatali@microsoft.com>
|
||||||
|
Date: Wed, 18 Nov 2020 18:30:30 -0800
|
||||||
|
Subject: [PATCH] meson: Adjust Clover's required LLVM modules
|
||||||
|
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index 6d1607c35a3..f828eb80faa 100644
|
||||||
|
--- b/meson.build
|
||||||
|
+++ a/meson.build
|
||||||
|
@@ -1479,10 +1479,9 @@
|
||||||
|
endif
|
||||||
|
if with_gallium_opencl
|
||||||
|
llvm_modules += [
|
||||||
|
- 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
|
||||||
|
- 'lto', 'option', 'objcarcopts', 'profiledata'
|
||||||
|
+ 'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
|
||||||
|
+ 'lto', 'option', 'objcarcopts', 'profiledata',
|
||||||
|
]
|
||||||
|
- llvm_optional_modules += ['frontendopenmp']
|
||||||
|
endif
|
||||||
|
if with_microsoft_clc
|
||||||
|
llvm_modules += ['target', 'linker', 'irreader', 'option', 'libdriver']
|
Loading…
Reference in New Issue
Block a user