gnu: pcre: Update to 8.41.
* gnu/packages/pcre.scm (pcre): Update to 8.41. [replacement]: Remove field. [source]: Remove patch. (pcre-8.41): Remove variable. * gnu/patches/pcre-CVE-2017-7186.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
5f7b070e97
commit
0b7f9806db
@ -907,7 +907,6 @@ dist_patch_DATA = \
|
||||
%D%/packages/patches/patchelf-rework-for-arm.patch \
|
||||
%D%/packages/patches/patchutils-xfail-gendiff-tests.patch \
|
||||
%D%/packages/patches/patch-hurd-path-max.patch \
|
||||
%D%/packages/patches/pcre-CVE-2017-7186.patch \
|
||||
%D%/packages/patches/pcre2-CVE-2017-7186.patch \
|
||||
%D%/packages/patches/pcre2-CVE-2017-8786.patch \
|
||||
%D%/packages/patches/perl-file-path-CVE-2017-6512.patch \
|
||||
|
@ -1,56 +0,0 @@
|
||||
Patch for <https://nvd.nist.gov/vuln/detail?vulnId=CVE-2017-7186>
|
||||
from <https://vcs.pcre.org/pcre?view=revision&revision=1688>.
|
||||
|
||||
--- trunk/pcre_internal.h 2016/05/21 13:34:44 1649
|
||||
+++ trunk/pcre_internal.h 2017/02/24 17:30:30 1688
|
||||
@@ -2772,6 +2772,9 @@
|
||||
extern const pcre_uint16 PRIV(ucd_stage2)[];
|
||||
extern const pcre_uint32 PRIV(ucp_gentype)[];
|
||||
extern const pcre_uint32 PRIV(ucp_gbtable)[];
|
||||
+#ifdef COMPILE_PCRE32
|
||||
+extern const ucd_record PRIV(dummy_ucd_record)[];
|
||||
+#endif
|
||||
#ifdef SUPPORT_JIT
|
||||
extern const int PRIV(ucp_typerange)[];
|
||||
#endif
|
||||
@@ -2780,9 +2783,15 @@
|
||||
/* UCD access macros */
|
||||
|
||||
#define UCD_BLOCK_SIZE 128
|
||||
-#define GET_UCD(ch) (PRIV(ucd_records) + \
|
||||
+#define REAL_GET_UCD(ch) (PRIV(ucd_records) + \
|
||||
PRIV(ucd_stage2)[PRIV(ucd_stage1)[(int)(ch) / UCD_BLOCK_SIZE] * \
|
||||
UCD_BLOCK_SIZE + (int)(ch) % UCD_BLOCK_SIZE])
|
||||
+
|
||||
+#ifdef COMPILE_PCRE32
|
||||
+#define GET_UCD(ch) ((ch > 0x10ffff)? PRIV(dummy_ucd_record) : REAL_GET_UCD(ch))
|
||||
+#else
|
||||
+#define GET_UCD(ch) REAL_GET_UCD(ch)
|
||||
+#endif
|
||||
|
||||
#define UCD_CHARTYPE(ch) GET_UCD(ch)->chartype
|
||||
#define UCD_SCRIPT(ch) GET_UCD(ch)->script
|
||||
|
||||
--- trunk/pcre_ucd.c 2014/06/19 07:51:39 1490
|
||||
+++ trunk/pcre_ucd.c 2017/02/24 17:30:30 1688
|
||||
@@ -38,6 +38,20 @@
|
||||
const pcre_uint32 PRIV(ucd_caseless_sets)[] = {0};
|
||||
#else
|
||||
|
||||
+/* If the 32-bit library is run in non-32-bit mode, character values
|
||||
+greater than 0x10ffff may be encountered. For these we set up a
|
||||
+special record. */
|
||||
+
|
||||
+#ifdef COMPILE_PCRE32
|
||||
+const ucd_record PRIV(dummy_ucd_record)[] = {{
|
||||
+ ucp_Common, /* script */
|
||||
+ ucp_Cn, /* type unassigned */
|
||||
+ ucp_gbOther, /* grapheme break property */
|
||||
+ 0, /* case set */
|
||||
+ 0, /* other case */
|
||||
+ }};
|
||||
+#endif
|
||||
+
|
||||
/* When recompiling tables with a new Unicode version, please check the
|
||||
types in this structure definition from pcre_internal.h (the actual
|
||||
field names will be different):
|
@ -5,6 +5,7 @@
|
||||
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
|
||||
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
|
||||
;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
@ -33,8 +34,7 @@
|
||||
(define-public pcre
|
||||
(package
|
||||
(name "pcre")
|
||||
(version "8.40")
|
||||
(replacement pcre-8.41)
|
||||
(version "8.41")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (list
|
||||
@ -43,10 +43,9 @@
|
||||
"pcre-" version ".tar.bz2")
|
||||
(string-append "mirror://sourceforge/pcre/pcre/"
|
||||
version "/pcre-" version ".tar.bz2")))
|
||||
(patches (search-patches "pcre-CVE-2017-7186.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1x7lpjn7jhk0n3sdvggxrlrhab8kkfjwl7qix0ypw9nlx8lpmqh0"))))
|
||||
"0c5m469p5pd7jip621ipq6hbgh7128lzh7xndllfgh77ban7wb76"))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs '("out" ;library & headers
|
||||
"bin" ;depends on Readline (adds 20MiB to the closure)
|
||||
@ -73,21 +72,6 @@ POSIX regular expression API.")
|
||||
(license license:bsd-3)
|
||||
(home-page "http://www.pcre.org/")))
|
||||
|
||||
(define pcre-8.41
|
||||
(package
|
||||
(inherit pcre)
|
||||
(version "8.41")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (list (string-append "mirror://sourceforge/pcre/pcre/"
|
||||
version "/pcre-" version ".tar.bz2")
|
||||
(string-append "ftp://ftp.csx.cam.ac.uk"
|
||||
"/pub/software/programming/pcre/"
|
||||
"pcre-" version ".tar.bz2")))
|
||||
(sha256
|
||||
(base32
|
||||
"0c5m469p5pd7jip621ipq6hbgh7128lzh7xndllfgh77ban7wb76"))))))
|
||||
|
||||
(define-public pcre2
|
||||
(package
|
||||
(name "pcre2")
|
||||
|
Loading…
Reference in New Issue
Block a user