gnu: hmmer: Update to 3.2.1.

* gnu/packages/bioinformatics.scm (hmmer): Update to 3.2.1.
[origin]: Remove patch.
[license]: Change to BSD-3.
[supported-systems]: New field.
* gnu/packages/patches/hmmer-remove-cpu-specificity.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Ben Woodcroft 2018-09-22 08:19:09 +10:00
parent 78b7b9dbe9
commit 05fb1e0017
No known key found for this signature in database
GPG Key ID: 2A6AD9F4AAC20DF6
3 changed files with 7 additions and 35 deletions

View File

@ -805,7 +805,6 @@ dist_patch_DATA = \
%D%/packages/patches/hdf-eos5-remove-gctp.patch \ %D%/packages/patches/hdf-eos5-remove-gctp.patch \
%D%/packages/patches/hdf-eos5-fix-szip.patch \ %D%/packages/patches/hdf-eos5-fix-szip.patch \
%D%/packages/patches/hdf-eos5-fortrantests.patch \ %D%/packages/patches/hdf-eos5-fortrantests.patch \
%D%/packages/patches/hmmer-remove-cpu-specificity.patch \
%D%/packages/patches/higan-remove-march-native-flag.patch \ %D%/packages/patches/higan-remove-march-native-flag.patch \
%D%/packages/patches/hubbub-sort-entities.patch \ %D%/packages/patches/hubbub-sort-entities.patch \
%D%/packages/patches/hurd-fix-eth-multiplexer-dependency.patch \ %D%/packages/patches/hurd-fix-eth-multiplexer-dependency.patch \

View File

@ -2936,18 +2936,15 @@ indexing scheme is called a @dfn{Hierarchical Graph FM index} (HGFM).")
(define-public hmmer (define-public hmmer
(package (package
(name "hmmer") (name "hmmer")
(version "3.1b2") (version "3.2.1")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
(uri (string-append (uri (string-append
"http://eddylab.org/software/hmmer" "http://eddylab.org/software/hmmer/hmmer-" version ".tar.gz"))
(version-major version) "/"
version "/hmmer-" version ".tar.gz"))
(sha256 (sha256
(base32 (base32
"0djmgc0pfli0jilfx8hql1axhwhqxqb8rxg2r5rg07aw73sfs5nx")) "171bivy6xhgjsz5nv53n81pc3frnwz29ylblawk2bv46szwjjqd5"))))
(patches (search-patches "hmmer-remove-cpu-specificity.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(native-inputs `(("perl" ,perl))) (native-inputs `(("perl" ,perl)))
(home-page "http://hmmer.org/") (home-page "http://hmmer.org/")
@ -2957,12 +2954,10 @@ indexing scheme is called a @dfn{Hierarchical Graph FM index} (HGFM).")
sequences, and for making protein sequence alignments. It implements methods sequences, and for making protein sequence alignments. It implements methods
using probabilistic models called profile hidden Markov models (profile using probabilistic models called profile hidden Markov models (profile
HMMs).") HMMs).")
(license (list license:gpl3+ ;; hmmer uses non-portable SSE intrinsics so building fails on other
;; The bundled library 'easel' is distributed ;; platforms.
;; under The Janelia Farm Software License. (supported-systems '("x86_64-linux" "i686-linux"))
(license:non-copyleft (license license:bsd-3)))
"file://easel/LICENSE"
"See easel/LICENSE in the distribution.")))))
(define-public htseq (define-public htseq
(package (package

View File

@ -1,22 +0,0 @@
This patch removes compilation flags which make the build for the machine
where compilation takes place, rendering the build not reproducible.
diff --git a/configure b/configure
index 8b6aaef..49a6afc 100755
--- a/configure
+++ b/configure
@@ -6125,14 +6125,6 @@ fi # guess arch
if test "x$ax_gcc_arch" != x -a "x$ax_gcc_arch" != xno; then
for arch in $ax_gcc_arch; do
- if test "x$acx_maxopt_portable" = xyes; then # if we require portable code
- flags="-mtune=$arch"
- # -mcpu=$arch and m$arch generate nonportable code on every arch except
- # x86. And some other arches (e.g. Alpha) don't accept -mtune. Grrr.
- case $host_cpu in i*86|x86_64*) flags="$flags -mcpu=$arch -m$arch";; esac
- else
- flags="-march=$arch -mcpu=$arch -m$arch"
- fi
for flag in $flags; do
as_CACHEVAR=`$as_echo "ax_cv_check_cflags__$flag" | $as_tr_sh`
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts $flag" >&5