gnu: Add jsoncpp-with-pkg-version.
* gnu/packages/patches/jsoncpp-pkg-config-version: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/serialization.scm (jsoncpp-with-pkg-version): New variable.
This commit is contained in:
parent
79fbbe5e4a
commit
03f99e14ed
@ -1267,6 +1267,7 @@ dist_patch_DATA = \
|
|||||||
%D%/packages/patches/json-c-CVE-2020-12762.patch \
|
%D%/packages/patches/json-c-CVE-2020-12762.patch \
|
||||||
%D%/packages/patches/json-c-0.13-CVE-2020-12762.patch \
|
%D%/packages/patches/json-c-0.13-CVE-2020-12762.patch \
|
||||||
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
|
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
|
||||||
|
%D%/packages/patches/jsoncpp-pkg-config-version.patch \
|
||||||
%D%/packages/patches/jacal-fix-texinfo.patch \
|
%D%/packages/patches/jacal-fix-texinfo.patch \
|
||||||
%D%/packages/patches/jamvm-1.5.1-aarch64-support.patch \
|
%D%/packages/patches/jamvm-1.5.1-aarch64-support.patch \
|
||||||
%D%/packages/patches/jamvm-1.5.1-armv7-support.patch \
|
%D%/packages/patches/jamvm-1.5.1-armv7-support.patch \
|
||||||
|
24
gnu/packages/patches/jsoncpp-pkg-config-version.patch
Normal file
24
gnu/packages/patches/jsoncpp-pkg-config-version.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
Taken from upstream: https://github.com/open-source-parsers/jsoncpp/issues/1235.
|
||||||
|
|
||||||
|
From ac2870298ed5b5a96a688d9df07461b31f83e906 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Derick Vigne <derickvigne@me.com>
|
||||||
|
Date: Tue, 26 Jan 2021 14:59:12 -0500
|
||||||
|
Subject: [PATCH] Fixed pkg-config Version
|
||||||
|
|
||||||
|
---
|
||||||
|
pkg-config/jsoncpp.pc.in | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/pkg-config/jsoncpp.pc.in b/pkg-config/jsoncpp.pc.in
|
||||||
|
index 632a377f5..2a2221069 100644
|
||||||
|
--- a/pkg-config/jsoncpp.pc.in
|
||||||
|
+++ b/pkg-config/jsoncpp.pc.in
|
||||||
|
@@ -5,7 +5,7 @@ includedir=@includedir_for_pc_file@
|
||||||
|
|
||||||
|
Name: jsoncpp
|
||||||
|
Description: A C++ library for interacting with JSON
|
||||||
|
-Version: @JSONCPP_VERSION@
|
||||||
|
+Version: @PROJECT_VERSION@
|
||||||
|
URL: https://github.com/open-source-parsers/jsoncpp
|
||||||
|
Libs: -L${libdir} -ljsoncpp
|
||||||
|
Cflags: -I${includedir}
|
@ -454,6 +454,25 @@ preserve existing comment in unserialization/serialization steps, making
|
|||||||
it a convenient format to store user input files.")
|
it a convenient format to store user input files.")
|
||||||
(license license:expat)))
|
(license license:expat)))
|
||||||
|
|
||||||
|
;; XXX: TODO(core-updates): Remove this package and apply the patch to the
|
||||||
|
;; jsoncpp package. This patch fixes the package version declared in the
|
||||||
|
;; pkg-config file.
|
||||||
|
(define-public jsoncpp-with-pkg-version
|
||||||
|
(package
|
||||||
|
(inherit jsoncpp)
|
||||||
|
(name "jsoncpp")
|
||||||
|
(version "1.9.4")
|
||||||
|
(home-page "https://github.com/open-source-parsers/jsoncpp")
|
||||||
|
(source (origin
|
||||||
|
(method git-fetch)
|
||||||
|
(uri (git-reference (url home-page) (commit version)))
|
||||||
|
(file-name (git-file-name name version))
|
||||||
|
(sha256
|
||||||
|
(base32
|
||||||
|
"0qnx5y6c90fphl9mj9d20j2dfgy6s5yr5l0xnzid0vh71zrp6jwv"))
|
||||||
|
(patches
|
||||||
|
(search-patches "jsoncpp-pkg-config-version.patch"))))))
|
||||||
|
|
||||||
;; Tensorflow does not build with jsoncpp 1.8.x. It is built with commit
|
;; Tensorflow does not build with jsoncpp 1.8.x. It is built with commit
|
||||||
;; 4356d9bba191e1e16ce7a92073cbf3e63564e973, which lies between version 1.7.2
|
;; 4356d9bba191e1e16ce7a92073cbf3e63564e973, which lies between version 1.7.2
|
||||||
;; and 1.7.3.
|
;; and 1.7.3.
|
||||||
|
Loading…
x
Reference in New Issue
Block a user