freebsd-ports/games/tornado/files/patch-aa
Edwin Groothuis ee2d77ff31 Update port: graphics/ayam remove stale dependency
Removed stale dependency on devel/log4cpp port.
	Noticed by:	Randolf Schultz rschultz at informatik.uni-rostock.de

PR:		ports/76001
Submitted by:	Igor Pokrovsky <ip@doom.homeunix.org>
2005-01-10 11:14:46 +00:00

44 lines
1.7 KiB
Plaintext

--- ../tornado-1.3.orig/Makefile Thu Nov 20 08:26:22 2003
+++ Makefile Sun Jan 9 14:21:24 2005
@@ -1,10 +1,9 @@
CC = gcc
-MAKE = make
-LDFLAGS = -lncurses
+MAKE = gmake
+LDFLAGS = -L/usr/local/lib -lncurses -lintl
OBJFILES = main.o draw.o erwin.o network.o scores.o
-PREFIX = /usr/local
-LOCALEPATH = /usr/local/share/locale
-CFLAGS = -Wall -O2 -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\""
+LOCALEPATH = ${PREFIX}/share/locale
+CFLAGS += -Wall -O2 -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\"" -I/usr/local/include
VERSION = `grep " VERSION" version.h | sed s/\"//g | sed s/\#define\ VERSION\ //`
LOCALES = de
MAN = doc/man
@@ -50,17 +49,17 @@
$(MAKE) -C $(MAN) install-man
- if [ -f "/var/games/tornado.scores" ]; then \
+ if [ -f "${PREFIX}/share/games/tornado.scores" ]; then \
echo "Skipping install of the highscores file. File exists."; \
- cat /var/games/tornado.scores | ./convert-highscorefile > score.tmp; \
- mv -f score.tmp /var/games/tornado.scores; \
- chmod a+rw-x "/var/games/tornado.scores"; \
+ cat ${PREFIX}/share/games/tornado.scores | ./convert-highscorefile > score.tmp; \
+ mv -f score.tmp ${PREFIX}/share/games/tornado.scores; \
+ chmod a+rw-x "${PREFIX}/share/games/tornado.scores"; \
else \
- if [ ! -d "/var/games" ]; then \
- mkdir /var/games; \
+ if [ ! -d "${PREFIX}/share/games" ]; then \
+ mkdir ${PREFIX}/share/games; \
fi; \
- install tornado.scores /var/games; \
- chmod a+w-x "/var/games/tornado.scores"; \
+ install tornado.scores ${PREFIX}/share/games; \
+ chmod a+w-x "${PREFIX}/share/games/tornado.scores"; \
fi
install-locale-data: