22667fa925
Some of the shared library magic is very hackish, however the net-snmp library building make-fu is hackish as well, so I don't feel bad about it. This commit also (re-)enables the host module for much more information. It also fixes a long standing bug where 'snmpwalk localhost public' would hang.
14 lines
413 B
Plaintext
14 lines
413 B
Plaintext
--- snmplib/Makefile.in.orig Mon Oct 2 11:41:46 2000
|
|
+++ snmplib/Makefile.in Wed Jan 17 18:29:44 2001
|
|
@@ -70,6 +70,10 @@
|
|
|
|
libsnmp.$(LIB_EXTENSION)$(LIB_VERSION): ${TOBJS}
|
|
$(LIB_LD_CMD) libsnmp.$(LIB_EXTENSION)$(LIB_VERSION) ${TOBJS}
|
|
+ ld -Bshareable -soname libsnmp.so.4 \
|
|
+ -o libsnmp.so ${OBJS}
|
|
+ ln -f libsnmp.so \
|
|
+ ../libsnmp.so.4
|
|
$(RANLIB) libsnmp.$(LIB_EXTENSION)$(LIB_VERSION)
|
|
|
|
installdirs:
|