freebsd-ports/net/libunp/files/patch-ag
Dan Moschuk a759fd52db libunp is the library used in W. Richard Steven's book "UNIX Network
Programming Volume 1, 2nd Edition".  It contains the library and headers
used in the examples as well as all programs from the text that compile on
FreeBSD systems.

PR: ports/14057
Submitted by: James FitzGibbon <james@targetnet.com>
1999-10-02 19:13:06 +00:00

21 lines
436 B
Plaintext

--- lib/Makefile.orig Fri Apr 11 17:38:27 1997
+++ lib/Makefile Thu Sep 30 11:34:21 1999
@@ -1,8 +1,16 @@
include ../Make.defines
-all: ${LIB_OBJS}
+CFLAGS += -I.. -I.
+
+all: libunp.a libunp_r.a
+
+libunp.a: ${LIB_OBJS}
ar rv ${LIBUNP_NAME} $?
${RANLIB} ${LIBUNP_NAME}
+
+libunp_r.a: ${LIB_THREADSAFE_OBJS}
+ ar rv ${LIBUNP_THREADSAFE_NAME} $?
+ ${RANLIB} ${LIBUNP_THREADSAFE_NAME}
clean:
rm -f ${PROGS} ${CLEANFILES}