freebsd-ports/lang/ruby19/files/patch-lib_mkmf.rb
Stanislav Sedov fae8e0f615 - Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in
  ruby 1.9 distribution already). Also move gem bits from
  ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend
  on gems or rake you should define USE_RUBYGEMS/USE_RAKE
  accordingly. Also RAKE_BIN variable is provided for
  pointing to the right rake executable.
- Rewrite RUBY_SCHEBANG in awk to eliminate build dependency
  on ruby.

Discussed with:	Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer)
Tested by:	ports@
2008-04-06 08:58:21 +00:00

12 lines
591 B
Ruby

--- lib/mkmf.rb.orig 2008-01-03 21:11:38.000000000 +0300
+++ lib/mkmf.rb 2008-01-03 21:11:55.000000000 +0300
@@ -148,7 +148,7 @@
path = File.expand_path($0)
$extmk = path[0, topdir.size+1] == topdir+"/" && %r"\A(ext|enc|tool)\z" =~ File.dirname(path[topdir.size+1..-1])
if not $extmk and File.exist?(($hdrdir = RbConfig::CONFIG["rubyhdrdir"]) + "/ruby/ruby.h")
- $topdir = $hdrdir
+ $topdir = $hdrdir + "/" + "#{CONFIG['arch']}/ruby/"
$top_srcdir = $hdrdir
$arch_hdrdir = $hdrdir + "/$(arch)"
elsif File.exist?(($hdrdir = ($top_srcdir ||= topdir) + "/include") + "/ruby.h") and