fae5a028c5
PR: 21942 Submitted by: Gregory Bond <gnb@itga.com.au> No response from: MAINTAINER (6 weeks timeout)
52 lines
1.5 KiB
Plaintext
52 lines
1.5 KiB
Plaintext
--- ./sys/unix/Makefile.src.orig Sat Aug 5 20:52:57 2000
|
|
+++ ./sys/unix/Makefile.src Fri Oct 13 10:10:21 2000
|
|
@@ -144,8 +144,8 @@
|
|
# flags for debugging:
|
|
# CFLAGS = -g -I../include
|
|
|
|
-CFLAGS = -O -I../include
|
|
-LFLAGS =
|
|
+CFLAGS += -O -I../include -I${X11BASE}/include
|
|
+LFLAGS = -L${X11BASE}/lib
|
|
|
|
# The Qt and Be window systems are written in C++, while the rest of
|
|
# NetHack is standard C. If using Qt, uncomment the LD line here to get
|
|
@@ -203,8 +203,8 @@
|
|
|
|
#
|
|
#
|
|
-WINSRC = $(WINTTYSRC)
|
|
-WINOBJ = $(WINTTYOBJ)
|
|
+WINSRC = $(WINTTYSRC) $(WINX11SRC)
|
|
+WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
|
|
|
|
# on some systems the termcap library is in -ltermcap or -lcurses
|
|
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
|
|
@@ -224,7 +224,7 @@
|
|
#
|
|
# libraries for X11
|
|
# If USE_XPM is defined in config.h, you will also need -lXpm here.
|
|
-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
|
|
+WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11 -lXpm
|
|
# WINX11LIB = -lXaw -lXmu -lXt -lX11
|
|
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
|
|
# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
|
|
@@ -244,7 +244,7 @@
|
|
# libraries for BeOS
|
|
WINBELIB = -lbe
|
|
|
|
-WINLIB = $(WINTTYLIB)
|
|
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
|
|
|
|
# any other strange libraries your system needs (for Sysunix only -- the more
|
|
# specialized targets should already be right)
|
|
@@ -271,7 +271,7 @@
|
|
# IRIX 4.0.x needs -lsun if NIS (YP) is being used for passwd file lookup
|
|
# LIBS = -lsun
|
|
#
|
|
-LIBS =
|
|
+LIBS = -lSM -lICE
|
|
|
|
# make NetHack
|
|
GAME = nethack
|