freebsd-ports/mail/imap-uw/files/patch-ac
Paul Traina 9104118561 Make this port compile again with changed source files.
This port needs to be converted to getting source files from a more
stable cache at FreeBSD, Inc. but I don't recall how to do it, so I
just did the annoying bits of making this damn thing compile again.
1998-02-23 23:15:17 +00:00

45 lines
1.2 KiB
Plaintext

--- src/imapd/Makefile.ORIG Thu Jan 22 15:42:52 1998
+++ src/imapd/Makefile Sun Feb 22 20:59:41 1998
@@ -31,8 +31,8 @@
# WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-ALERT=/etc/imapd.alert
-ANO=/etc/anonymous.newsgroups
+ALERT=$(PREFIX)/etc/imapd.alert
+ANO=$(PREFIX)/etc/anonymous.newsgroups
SHELL= /bin/sh
# The "Manage Mail" menu item of Netscape Messager puts up an error message
@@ -55,7 +55,7 @@
CC = `cat $C/CCTYPE`
CFLAGS = -I$C `cat $C/CFLAGS` -DALERTFILE=\"$(ALERT)\" -DANOFILE=\"$(ANO)\" \
$(EXTRACFLAGS)
-LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
+LDFLAGS = -L$C -lc-client `cat $C/LDFLAGS`
all: imapd
--- src/ipopd/Makefile.ORIG Thu Mar 14 13:18:17 1996
+++ src/ipopd/Makefile Sun Feb 22 20:58:29 1998
@@ -39,7 +39,7 @@
CC = `cat $C/CCTYPE`
CFLAGS = -I$C `cat $C/CFLAGS`
-LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
+LDFLAGS = -L$C -lc-client `cat $C/LDFLAGS`
ipopd: ipop2d ipop3d
--- src/mtest/Makefile.ORIG Thu Jan 22 15:41:45 1998
+++ src/mtest/Makefile Sun Feb 22 20:58:56 1998
@@ -39,7 +39,7 @@
CC = `cat $C/CCTYPE`
CFLAGS = -I$C `cat $C/CFLAGS`
-LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
+LDFLAGS = -L$C -lc-client `cat $C/LDFLAGS`
all: mtest