freebsd-ports/cad/sis/files/patch-ay
Ade Lovett 358b49a600 Support CC/CFLAGS/PREFIX/X11BASE/MAKE properly
Sort pkg/PLIST

PR:		20418
Submitted by:	Ports Fury
2000-09-16 18:40:55 +00:00

34 lines
904 B
Plaintext

--- utility/Makefile.orig Sat Jul 16 07:55:23 1994
+++ utility/Makefile Fri Aug 4 00:11:22 2000
@@ -67,10 +67,10 @@
# for HPUX
SHELL = /bin/sh
-MAKE = /bin/make
+#MAKE = /bin/make
AR = ar
RANLIB = ranlib
-CPLUSPLUS = g++
+CPLUSPLUS = ${CXX}
OCTTOOLS=/projects/octtools/octtools/${MACHINE}
CADROOT = $$OCTTOOLS
@@ -79,7 +79,7 @@
LINTCREATEFLAG = -C
LINTEXTRAS =
DBGFLAG =
-OPTFLAG =
+#OPTFLAG =
# an alternative if you want links in the installation locations
# back to the source directories would be:
@@ -158,7 +158,7 @@
"VPATH=${VPATH}"
INCLUDE = -I$(CAD)/include
-CFLAGS = ${OPTFLAG} ${DBGFLAG} ${INCLUDE} '-DCADROOT="${CADROOT}"'
+CFLAGS += ${OPTFLAG} ${DBGFLAG} ${INCLUDE} '-DCADROOT="${CADROOT}"'
VERSION = "-DCUR_DATE=\"`date | awk '{print $$2, $$3, $$6}'`\"" \
"-DCUR_TIME=\"`date | awk '{print $$4}'`\""
LINTFLAGS= ${INCLUDE} '-DCADROOT="${CADROOT}"' ${LINTEXTRAS}