freebsd-ports/cad/sis/files/patch-ag
Ade Lovett 358b49a600 Support CC/CFLAGS/PREFIX/X11BASE/MAKE properly
Sort pkg/PLIST

PR:		20418
Submitted by:	Ports Fury
2000-09-16 18:40:55 +00:00

40 lines
955 B
Plaintext

--- blif2vst/Makefile.orig Fri Jul 15 08:46:34 1994
+++ blif2vst/Makefile Fri Aug 4 00:14:03 2000
@@ -15,22 +15,22 @@
# for HPUX
SHELL = /bin/sh
-MAKE = /bin/make
+#MAKE = /bin/make
AR = ar
RANLIB = ranlib
-CPLUSPLUS = g++
+CPLUSPLUS = ${CXX}
OCTTOOLS = /projects/octtools/octtools/$(MACHINE)
SIS = /usr/eesww/sis
UTILS = ${OCTTOOLS}/utils
-XINCLOC = -I/usr/local/X11R4/include
-XLIBLOC = -L/usr/local/X11R4/lib
+XINCLOC = -I${X11BASE}/include
+XLIBLOC = -L${X11BASE}/lib
LINTCREATEFLAG = -C
LINTEXTRAS =
LDEXTRAS =
DBGFLAG =
-OPTFLAG = -O
+#OPTFLAG = -O
# an alternative if you want links in the installation locations
# back to the source directories would be:
@@ -104,7 +104,7 @@
"VPATH=${VPATH}"
INCLUDE =
-CFLAGS = ${OPTFLAG} ${DBGFLAG} ${INCLUDE}
+CFLAGS += ${OPTFLAG} ${DBGFLAG} ${INCLUDE}
YFLAGS = -d
VERSION = "-DCUR_DATE=\"`date | awk '{print $$2, $$3, $$6}'`\"" \
"-DCUR_TIME=\"`date | awk '{print $$4}'`\""