9b1a5c1c07
The referenced change made NO_INSTALLLIB, NO_MAN, and NO_PROFILE into errors causing these ports that declare them and use the FreeBSD make infrastructure as part of their build to fail. When the offending variables occur in a BSD Makefile, NO_MAN becomes MAN= and NO_INSTALLLIB and NO_PROFILE become MK_INSTALLLIB=no and MK_PROFILE=no respectively. When declared in the environment they become WITHOUT_<FOO>. Also GC NO_MANCOMPRESSED which doesn't do anything. In the case of devel/libpasori, this change accomplished the same thing as the change in r518434, but more directly (fix the Makefiles rather than patching them after they are installed).
17 lines
310 B
Plaintext
17 lines
310 B
Plaintext
--- lib/Makefile.orig
|
|
+++ lib/Makefile
|
|
@@ -5,8 +5,10 @@
|
|
iasclt.c commsrv.c commclt.c obexsrv.c obexclt.c options.c \
|
|
actisys.c girbil.c litelink.c jeteye.c sendobex.c redlink.c
|
|
|
|
-NOPROFILE= yes
|
|
-NOPIC= yes
|
|
-MKLINKLIB= no
|
|
+MK_PROFILE= no
|
|
+NO_PIC= yes
|
|
+MK_LINKLIB= no
|
|
+
|
|
+install:
|
|
|
|
.include <bsd.lib.mk>
|