freebsd-ports/net/ladvd/Makefile
Beat Gaetzi fc229c03a7 - Update to 0.8.5
- Adjust COMMENT
- Add UID and GID entries for net/ladvd

PR:		ports/138734
Submitted by:	Sten Spans <sten AT blinkenlights.nl> (maintainer)
Feature safe:	yes
2009-09-17 21:35:12 +00:00

38 lines
814 B
Makefile

# New ports collection makefile for: ladvd
# Date Created: 27 Jul 2008
# Whom: sten@blinkenlights.nl
#
# $FreeBSD$
#
PORTNAME= ladvd
PORTVERSION= 0.8.5
CATEGORIES= net
MASTER_SITES= http://blinkenlights.nl/software/ladvd/
MAINTAINER= sten@blinkenlights.nl
COMMENT= A minimal CDP/LLDP daemon
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-chroot-dir=/var/empty
PORTDOCS= *
MAN8= ladvd.8
USE_RC_SUBR+= ladvd
SUB_FILES= pkg-message pkg-install
post-patch:
.if defined(NOPORTDOCS)
@@${REINPLACE_CMD} 's|install-data-am: install-dist_docDATA|install-data-am:|' \
${WRKSRC}/doc/Makefile.in
.endif
post-install:
@${ECHO} "==> Creating custom user to run ladvd..."
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>