freebsd-ports/net/iaxmodem/files/patch-lib_libiax2_src_iax.c
Rong-En Fan d3ae086cc4 - Update to 0.1.14
- Replace the build system to hand-written configure/Makefile
- Mark it as BROKEN on 4.x: does not compile

PR:		ports/101961
Submitted by:	Anish Mistry <amistry at am-productions.biz>
Approved by:	Filippo Natali" <filippo.natali at gmail.com> (maintainer)
2006-08-21 04:30:49 +00:00

32 lines
868 B
C

--- lib/libiax2/src/iax.c.orig Mon Jun 12 15:54:46 2006
+++ lib/libiax2/src/iax.c Thu Jun 15 14:22:17 2006
@@ -44,6 +44,7 @@
#else
#include <netdb.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <sys/time.h>
@@ -64,9 +64,9 @@
#include <arpa/inet.h>
#include <time.h>
-#if !defined(MACOSX) && !defined(__OpenBSD__)
+#if !defined(MACOSX) && !defined(__OpenBSD__) && !defined(__FreeBSD__)
#include <malloc.h>
-#if !defined(SOLARIS)
+#if !defined(SOLARIS) && !defined(__FreeBSD__)
#include <error.h>
#endif
#endif
@@ -97,7 +97,7 @@
#ifdef MACOSX
#define IAX_SOCKOPTS MSG_DONTWAIT
#else
-#if defined(SOLARIS) || defined(__OpenBSD__)
+#if defined(SOLARIS) || defined(__OpenBSD__) || defined(__FreeBSD__)
#define IAX_SOCKOPTS MSG_DONTWAIT
#else /* Linux and others */
#define IAX_SOCKOPTS MSG_DONTWAIT | MSG_NOSIGNAL