freebsd-ports/www/firefox15/files/patch-config-rules.mk
Joe Marcus Clarke 6593022e89 Add Firefox after a repo copy from mozilla-firebird. Firefox is the next
release of the Firebird web browser with a new name to avoid conflicts with
the Firebird database.  This is version 0.8.

http://www.mozilla.org/products/firefox/releases/

* Update to 0.8 and change name to firefox [1]
* Make PLIST from a fake installation [1]
* Restore original credit and portname in Makefile [1]
* Optionally install headers and IDL files [2]
* Use PERL instead of REINPLACE_CMD in a few places [1]
* Use OPTIONS
* Enable the Inspector extension
* Fix another possible esound related problem
* Enable basic optimizations if WITH_DEBUG is not specified

PR:		62631 [2]
Submitted by:	trevor [1] [2]
2004-02-11 07:16:17 +00:00

17 lines
323 B
Makefile

$FreeBSD$
--- config/rules.mk.orig Tue Aug 26 13:28:47 2003
+++ config/rules.mk Sun Feb 1 15:11:41 2004
@@ -444,7 +444,11 @@
ifeq ($(OS_ARCH),FreeBSD)
ifdef IS_COMPONENT
+ifneq (,$(filter alpha ia64,$(OS_TEST)))
+EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic -lc
+else
EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic
+endif
endif
endif