630a8f7c9d
Submitted by: tg
32 lines
1.0 KiB
Plaintext
32 lines
1.0 KiB
Plaintext
--- setup.py.orig Thu Dec 20 18:33:42 2001
|
|
+++ setup.py Sun Jan 20 11:00:24 2002
|
|
@@ -111,6 +111,16 @@
|
|
|
|
|
|
#----------------------------------------------------------------------
|
|
+# Check for some environment variables
|
|
+#----------------------------------------------------------------------
|
|
+
|
|
+try: gtk_config = os.environ['GTK_CONFIG']
|
|
+except KeyError: gtk_config = 'gtk-config'
|
|
+
|
|
+try: sys_libs = string.split(os.environ['LIBS'])
|
|
+except KeyError: sys_libs = []
|
|
+
|
|
+#----------------------------------------------------------------------
|
|
# Check for build flags on the command line
|
|
#----------------------------------------------------------------------
|
|
|
|
@@ -277,9 +287,10 @@
|
|
]
|
|
libdirs = []
|
|
libs = []
|
|
+ libs.extend(sys_libs)
|
|
|
|
cflags = os.popen(WX_CONFIG + ' --cxxflags', 'r').read()[:-1] + ' ' + \
|
|
- os.popen('gtk-config --cflags', 'r').read()[:-1]
|
|
+ os.popen(gtk_config + ' --cflags', 'r').read()[:-1]
|
|
cflags = string.split(cflags)
|
|
|
|
lflags = os.popen(WX_CONFIG + ' --libs', 'r').read()[:-1]
|