05b2ac3b5b
- install configuration files with .dist suffix so that users configuration files are not deleted on package removal - create ${PREFIX}/var/netsaint/rw directory needed for correct operation of CGI script - fix netsaint.log file permission problem - depend on netsaint-plugins port PR: 26328 Submitted by: maintainer
43 lines
1.3 KiB
Plaintext
43 lines
1.3 KiB
Plaintext
--- configure.orig Thu Mar 1 04:54:12 2001
|
|
+++ configure Thu Mar 1 21:58:09 2001
|
|
@@ -11,7 +11,7 @@
|
|
ac_help=
|
|
ac_default_prefix=/usr/local
|
|
# Any additions from configure.in:
|
|
-ac_default_prefix=/usr/local/netsaint
|
|
+#ac_default_prefix=/usr/local/netsaint
|
|
ac_help="$ac_help
|
|
--with-netsaint-user=<user> sets user name to run netsaint"
|
|
ac_help="$ac_help
|
|
@@ -562,9 +562,9 @@
|
|
# Prefer explicitly selected file to automatically selected ones.
|
|
if test -z "$CONFIG_SITE"; then
|
|
if test "x$prefix" != xNONE; then
|
|
- CONFIG_SITE="$prefix/share/config.site $prefix/etc/config.site"
|
|
+ CONFIG_SITE="$prefix/share/netsaint/config.site $prefix/etc/netsaint/config.site"
|
|
else
|
|
- CONFIG_SITE="$ac_default_prefix/share/config.site $ac_default_prefix/etc/config.site"
|
|
+ CONFIG_SITE="$ac_default_prefix/share/netsaint/config.site $ac_default_prefix/etc/netsaint/config.site"
|
|
fi
|
|
fi
|
|
for ac_site_file in $CONFIG_SITE; do
|
|
@@ -1298,6 +1298,9 @@
|
|
LDFLAGS="${LDFLAGS} -L${withval}"
|
|
LD_RUN_PATH="${withval}${LD_RUN_PATH:+:}${LD_RUN_PATH}"
|
|
|
|
+else
|
|
+ LDFLAGS="${LDFLAGS} -L/usr/local/lib"
|
|
+ LD_RUN_PATH="/usr/local/ib${LD_RUN_PATH:+:}${LD_RUN_PATH}"
|
|
fi
|
|
|
|
# Check whether --with-gd-inc or --without-gd-inc was given.
|
|
@@ -1305,6 +1308,8 @@
|
|
withval="$with_gd_inc"
|
|
|
|
CFLAGS="${CFLAGS} -I${withval}"
|
|
+else
|
|
+ CFLAGS="${CFLAGS} -I/usr/local/include/gd"
|
|
|
|
fi
|
|
|