freebsd-ports/multimedia/audacious/files/patch-src-audacious-Makefile
Oliver Lehmann 9ce585a608 update audacious to 2.1
bump portrevision on dependant ports
2009-07-26 06:15:16 +00:00

54 lines
1.2 KiB
Plaintext

--- src/audacious/Makefile.orig 2009-07-07 00:39:12.000000000 +0200
+++ src/audacious/Makefile 2009-07-18 09:41:46.000000000 +0200
@@ -127,15 +127,8 @@
include ../../buildsys.mk
-ifeq ($(USE_DBUS),yes)
-CPPFLAGS += -I../libaudclient
-DBUS_BINDINGS = dbus-server-bindings.h dbus-client-bindings.h
-LIBS += -L../libaudclient -laudclient
-endif
-
-pre-depend: ${DBUS_BINDINGS}
-
-CPPFLAGS += -DHAVE_CONFIG_H \
+CPPFLAGS = -I.. -I../.. \
+ -DHAVE_CONFIG_H \
${MOWGLI_CFLAGS} \
${GLIB_CFLAGS} \
${GTHREAD_CFLAGS} \
@@ -149,13 +142,12 @@
${SIMD_CFLAGS} \
-D_AUDACIOUS_CORE \
${EGGSM_CFLAGS} \
- -I.. -I../.. \
-I./intl \
-I. \
-I../libSAD \
-I../libaudcore
-LIBS += ${LDADD} \
+LIBS = \
-L../libaudcore -laudcore \
${LIBINTL} \
${SAMPLERATE_LIBS} \
@@ -168,7 +160,16 @@
${DBUS_LIBS} \
${MOWGLI_LIBS} \
${LIBMCS_LIBS} \
- ${REGEX_LIBS}
+ ${REGEX_LIBS} \
+ ${LDADD}
+
+ifeq ($(USE_DBUS),yes)
+CPPFLAGS += -I../libaudclient
+DBUS_BINDINGS = dbus-server-bindings.h dbus-client-bindings.h
+LIBS += -L../libaudclient -laudclient
+endif
+
+pre-depend: ${DBUS_BINDINGS}
LDFLAGS += ${PROG_IMPLIB_LDFLAGS} ${AUDLDFLAGS}