bfac2f377f
is going to be NO_PACKAGE. It uses wish4.0 too. It's the first port to depend on Tk-4.0!
100 lines
3.3 KiB
Plaintext
100 lines
3.3 KiB
Plaintext
--- ./Makefile.org Fri Aug 18 17:07:54 1995
|
|
+++ ./Makefile Fri Aug 18 23:03:50 1995
|
|
@@ -35,28 +35,28 @@
|
|
### you need to localize the paths on these lines
|
|
|
|
# Tk's wish MUST be compiled with Tcl 7.4/Tk 4.0 or later versions
|
|
-WISH = /usr/sww/tcl-7.4b4/bin/wish
|
|
+#WISH = /usr/sww/tcl-7.4b4/bin/wish
|
|
#WISH = /home/orodruin/h/bair/phelps/bin/alpha/wish
|
|
-#WISH = /usr/local/bin/wish
|
|
+WISH = /usr/local/bin/wish4.0
|
|
|
|
# the executable `tkman' is placed in BINDIR
|
|
# this should be a directory that's in your bin PATH
|
|
-BINDIR = /home/auspex/h/bair/phelps/bin
|
|
-#BINDIR = /usr/local/bin
|
|
+#BINDIR = /home/auspex/h/bair/phelps/bin
|
|
+BINDIR = /usr/local/bin
|
|
|
|
# directory in which to place the manual page. The help information
|
|
# is maintained in HTML, from which the [tn]roff version is
|
|
# automatically generated.
|
|
-MANDIR = /home/auspex/h/bair/phelps/man/man1
|
|
+#MANDIR = /home/auspex/h/bair/phelps/man/man1
|
|
#MANDIR = /usr/sww/X11/man/man1
|
|
-#MANDIR = /usr/local/man/man1
|
|
+MANDIR = /usr/local/man/man1
|
|
|
|
|
|
# # # MACHINE DEPENDENCIES # # #
|
|
|
|
-manformat = {tbl | neqn | nroff -man | col}
|
|
+#manformat = {tbl | neqn | nroff -man | col}
|
|
# alternatively
|
|
-#manformat = {groff -Tascii -te -mandoc}
|
|
+manformat = {groff -Tascii -te -mandoc}
|
|
# Ultrix users should uncomment the following line
|
|
#manformat = {tbl | nroff -man | col}
|
|
|
|
@@ -120,10 +120,10 @@
|
|
# so how can you lose?
|
|
|
|
# BY DEFAULT ON
|
|
-glimpse = glimpse
|
|
+#glimpse = glimpse
|
|
# IF YOU DON'T WANT TO BOTHER WITH GLIMPSE, you can disable it here
|
|
# ALSO DISABLE GLIMPSEINDEX BELOW
|
|
-#glimpse = ""
|
|
+glimpse = ""
|
|
# give the full path, if you'd like
|
|
#glimpse = /usr/sww/bin/glimpse
|
|
# variations (refer to the Glimpse manual page)
|
|
@@ -150,9 +150,9 @@
|
|
# (`-debug' option), obtain the problemmatic glimpseindex command,
|
|
# and make sure it works when executed by hand.
|
|
|
|
-glimpseindex = glimpseindex
|
|
+#glimpseindex = glimpseindex
|
|
# IF YOU DON'T WANT TO BOTHER WITH GLIMPSE, DISABLE IT HERE *ALSO*
|
|
-#glimpseindex = ""
|
|
+glimpseindex = ""
|
|
# produce a larger index ("7-9%" of source text) allowing faster search w/"-o"
|
|
# Need -o or -b if using -N above.
|
|
#glimpseindex = "glimpseindex -o"
|
|
@@ -170,7 +170,7 @@
|
|
# default MANPATH to use if user doesn't have a MANPATH environment variable set.
|
|
# Leave this empty to have TkMan calculate a MANPATH based on a users PATH
|
|
# (like Perl man does).
|
|
-manpathdef = ""
|
|
+manpathdef = /usr/share/man:/usr/local/man:/usr/X11R6/man
|
|
#manpathdef = /usr/man:/usr/local/man
|
|
#manpathdef = /usr/man:/usr/local/man:/usr/sww/man:/usr/sww/X11/man
|
|
# for SGI
|
|
@@ -223,13 +223,13 @@
|
|
|
|
# if you don't want to RosettaMan (rman) in your PATH, make the name fully qualified
|
|
# (that's probably a good idea if tkman is installed on a central server)
|
|
-rman = rman
|
|
+rman = /usr/local/bin/rman
|
|
#rman = /home/orodruin/h/bair/phelps/bin/alpha/rman
|
|
|
|
-manprint = {tbl | eqn | troff -man -t | lpr -t}
|
|
+#manprint = {tbl | eqn | troff -man -t | lpr -t}
|
|
# alternatives
|
|
#manprint = {tbl | eqn | psroff -man}
|
|
-#manprint = {groff -man -Tps -te -l}
|
|
+manprint = {groff -man -Tps -te -l}
|
|
#manprint = {groff -man -Tascii -te -l}
|
|
# printing string for preformatted pages without [tn]roff source
|
|
catprint = lpr
|
|
@@ -330,7 +330,7 @@
|
|
$(CP) tkman $(BINDIR)
|
|
chmod +x $(BINDIR)/tkman
|
|
$(CP) tkman.1 $(MANDIR)
|
|
- @echo 'You also need RosettaMan to run TkMan.'
|
|
+# @echo 'You also need RosettaMan to run TkMan.'
|
|
|
|
test: dox tkman
|
|
cp tkman $(BINDIR)
|