freebsd-ports/net/libunp/files/patch-aj
Dan Moschuk a759fd52db libunp is the library used in W. Richard Steven's book "UNIX Network
Programming Volume 1, 2nd Edition".  It contains the library and headers
used in the examples as well as all programs from the text that compile on
FreeBSD systems.

PR: ports/14057
Submitted by: James FitzGibbon <james@targetnet.com>
1999-10-02 19:13:06 +00:00

17 lines
432 B
Plaintext

--- libgai/Makefile.orig Mon Jun 2 18:03:30 1997
+++ libgai/Makefile Thu Sep 30 11:34:11 1999
@@ -6,9 +6,13 @@
# appear in the book (too much clutter, given the amount of conditional
# testing for all the code in this directory).
+CFLAGS += -I..
+
all: ${LIBGAI_OBJS}
ar rv ${LIBUNP_NAME} $?
${RANLIB} ${LIBUNP_NAME}
+ ar rv ${LIBUNP_THREADSAFE_NAME} $?
+ ${RANLIB} ${LIBUNP_THREADSAFE_NAME}
PROGS = testga test1