04b79ace72
- update mastersite - install more docs, use DOCSDIR - properly support NOPORTDOCS in pkg-plist - sync pkg-descr with current features - update ngrep.c (the t->tm_mon+1 change has been integrated in 1.40) - remove patch-Makefile.in (no longer necessary) PR: 29588 Submitted by: Pete Fritchman <petef@databits.net>
20 lines
440 B
C
20 lines
440 B
C
--- ngrep.c.orig Wed Aug 8 23:36:09 2001
|
|
+++ ngrep.c Wed Aug 8 23:36:31 2001
|
|
@@ -62,6 +62,7 @@
|
|
|
|
#include "ngrep.h"
|
|
|
|
+extern FILE *yyin;
|
|
|
|
static char rcsver[] = "$Revision: 1.18 $";
|
|
|
|
@@ -232,7 +233,7 @@
|
|
filter = get_filter(&argv[optind-1]);
|
|
|
|
#ifdef NEED_RESTART
|
|
- PCAP_RESTART();
|
|
+ PCAP_RESTART(yyin);
|
|
#endif
|
|
if (pcap_compile(pd, &pcapfilter, filter, 0, mask.s_addr)) {
|
|
pcap_perror(pd, "pcap compile");
|