4f2162a0d5
since this is unversioned. o Add booktree capture support with patches kindly supplied by "Steve O'Hara-Smith" <steve@sohara.org>. Work is in progress to get these merged back into ffmpeg's CVS repo o Add WITH_MP3 for lame mp3 support o Add WITH_VORBIS for vorbis support o Install shared library for the first time, begin versioning at 0 Reviewed by: freebsd-multimedia mailing list, "Steve O'Hara-Smith" <steve@sohara.org>, Anish Mistry <mistry.7@osu.edu>
21 lines
639 B
Plaintext
21 lines
639 B
Plaintext
--- libav/Makefile.orig Tue Oct 8 13:54:16 2002
|
|
+++ libav/Makefile Tue Oct 8 13:54:30 2002
|
|
@@ -6,7 +6,7 @@
|
|
|
|
VPATH=$(SRC_PATH)/libav
|
|
|
|
-CFLAGS= $(OPTFLAGS) -Wall -g -I.. -I$(SRC_PATH) -I$(SRC_PATH)/libavcodec -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
|
|
+CFLAGS= $(OPTFLAGS) -Wall -I.. -I$(SRC_PATH) -I$(SRC_PATH)/libavcodec -DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
|
|
|
|
OBJS= utils.o cutils.o allformats.o
|
|
|
|
@@ -17,7 +17,7 @@
|
|
OBJS+= avio.o aviobuf.o file.o
|
|
|
|
ifeq ($(CONFIG_VIDEO4LINUX),yes)
|
|
-OBJS+= grab.o
|
|
+OBJS+= grab_bsdbktr.o
|
|
endif
|
|
|
|
ifeq ($(CONFIG_AUDIO_OSS),yes)
|