freebsd-ports/sysutils/shim/files/patch-Cryptlib-OpenSSL-Makefile
Vinícius Zavam b3cd746e21 sysutils/shim: introduce new ARCH support (i386)
Makefile
        bump PORTREVISION;
        USE_CSTD: gnu89 became gnu99 [0];

    files/
        *: if ARCH=i386, replaces ARCH with ia32;
        elf_ia32_efi.lds: sync OUTPUT_FORMAT [1];
        MokManager.c: used UINT32 for MokNum.

Reported by:	pkg-fallout
Approved by:	araujo (mentor)
Differential Revision:	https://reviews.freebsd.org/D18572

[0] shim.c:2176:3: error: this decimal constant is unsigned only in ISO C90
[1] patch-elf_x86_64_efi.lds always appended -freebsd as OUTPUT_FORMAT
2018-12-19 17:30:22 +00:00

13 lines
313 B
Plaintext

--- Cryptlib/OpenSSL/Makefile.orig 2015-06-30 18:20:12 UTC
+++ Cryptlib/OpenSSL/Makefile
@@ -1,3 +1,9 @@
+ifeq ($(ARCH),amd64)
+ override ARCH = x86_64
+endif
+ifeq ($(ARCH),i386)
+ override ARCH = ia32
+endif
EFI_INCLUDES = -I../Include -I$(EFI_INCLUDE) -I$(EFI_INCLUDE)/$(ARCH) -I$(EFI_INCLUDE)/protocol