freebsd-ports/comms/conserver/files/patch-aa
Peter Wemm 05de5b58c5 Specify the port rather than depending /etc/services or the yp
services.byname table to be bashed.
1997-11-22 15:26:24 +00:00

34 lines
989 B
Plaintext

--- conserver/Makefile.orig Sat Nov 22 20:42:18 1997
+++ conserver/Makefile Sat Nov 22 20:43:24 1997
@@ -8,6 +8,6 @@
# I would not change the name, you have to much with the docs then...
PROG= conserver
-ETC= ${DESTDIR}/usr/local/etc
-DOC= ${DESTDIR}/usr/local/man
+ETC= ${DESTDIR}/usr/local/sbin
+DOC= ${DESTDIR}/usr/local/man/man8
# if we have to PUCC ptyd daemon we can use it to get ptys, else use fallback.o
@@ -25,5 +25,5 @@
INCLUDE=
DEBUG=-O
-CDEFS= -DSUN5 -DHAVE_PTYD=0 -DDO_VIRTUAL=1
+CDEFS= -DFREEBSD -DHAVE_PTYD=0 -DDO_VIRTUAL=1 -DPORT=782
CFLAGS= ${DEBUG} ${CDEFS} ${INCLUDE}
@@ -42,5 +42,5 @@
${PROG}:$P ${OBJ}
- ${CC} -o $@ ${CFLAGS} ${OBJ} ${PUCCLIB} -lsocket -lnsl
+ ${CC} -o $@ ${CFLAGS} ${OBJ} ${PUCCLIB} -lcrypt
clean: FRC
@@ -60,5 +60,6 @@
install: all dirs FRC
- install -c -s ${PROG} ${ETC}/${PROG}
+ install -c -s -o bin -g bin -m 555 ${PROG} ${ETC}/${PROG}
+ install -c -o bin -g bin -m 444 ${MAN} ${DOC}/conserver.8
lint: ${HDR} ${SRC} FRC