0faf48ffbe
at UW. Improvements include TLS and SSL support fully integrated into the code base (requires OpenSSL), support for remote address books, improved rules-based filtering, and new filter options. * Bugs fixed include longer folder names, temp file cleanup, mail sorted by filters more accurately, et al. * Re-generate almost all of the patches to clean out more of the fuzz.
33 lines
821 B
Plaintext
33 lines
821 B
Plaintext
--- imap/src/osdep/unix/Makefile.orig Wed Aug 29 12:15:15 2001
|
|
+++ imap/src/osdep/unix/Makefile Fri Sep 28 00:08:24 2001
|
|
@@ -97,7 +97,7 @@
|
|
# Commands possibly overriden by the individual port
|
|
|
|
ARRC=ar rc
|
|
-CC=cc
|
|
+#CC=cc
|
|
LN=ln -s
|
|
RANLIB=ranlib
|
|
|
|
@@ -115,7 +115,7 @@
|
|
dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
|
|
rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
|
|
unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o
|
|
-CFLAGS=-g
|
|
+CFLAGS+=$(BASECFLAGS) $(EXTRACFLAGS)
|
|
|
|
CAT=cat
|
|
MAKE=make
|
|
@@ -217,8 +217,9 @@
|
|
SPOOLDIR=/var \
|
|
ACTIVEFILE=/usr/local/news/lib/active \
|
|
RSHPATH=/usr/bin/rsh \
|
|
- BASECFLAGS="-g -O -pipe" \
|
|
- BASELDFLAGS="-lcrypt"
|
|
+ LOCKPGM=$(PREFIX)/libexec/mlock \
|
|
+ BASECFLAGS="-DNFSKLUDGE" \
|
|
+ BASELDFLAGS="-lpam -lcrypt"
|
|
|
|
bsi: # BSD/i386
|
|
$(BUILD) `$(CAT) SPECIALS` OS=$@ \
|