freebsd-ports/lang/gforth/files/patch-engine::Makefile.in
Mark Linimon a39bc0b003 CONFIGURE_ENV and MAKE_ENV added; PLIST_SUB updated; WORDSIZE
and BYTEORDER added; EMPTY_DIRS split (the second one will be deleted
upon 0.6.2 update, if any); SIZE added to distinfo; plist generalized;
-fno-inline and FPE_* build fix added from 0.6.2.

The 0.6.2 runtime causes a Segmentation Fault at compilation time,
so, no update is planned right now... sorry.

PR:		ports/63991
Submitted by:	Cyrille Lefevre <cyrille.lefevre@laposte.net>
2004-03-17 20:03:17 +00:00

13 lines
656 B
Plaintext

--- engine/Makefile.in.orig Sun Mar 9 16:06:46 2003
+++ engine/Makefile.in Tue Mar 9 14:47:19 2004
@@ -72,7 +72,8 @@
XCFLAGS = @CFLAGS@
XDEFINES = @DEFS@
SWITCHES = $(XCFLAGS) $(XDEFINES)
-ENGINE_FLAGS = @ENGINE_FLAGS@ -fno-defer-pop -fcaller-saves
+#use -fno-inline to avoid register problems with asinh, atanh on gcc-3.3 on 386
+ENGINE_FLAGS = @ENGINE_FLAGS@ -fno-defer-pop -fcaller-saves -fno-inline
DEBUGFLAG = @DEBUGFLAG@
CFLAGS = $(DEBUGFLAG) -I$(srcdir)/../arch/$(machine) -I. -O2 -Wall $(SWITCHES) -DDEFAULTPATH=\"$(FORTHPATH)\"
CFLAGS2 = $(DEBUGFLAG) -I$(srcdir)/../arch/$(machine) -I. -O2 -Wall $(SWITCHES) -DDEFAULTPATH=\"$(FORTHPATH)\"