freebsd-ports/security/openssl-beta/files/patch-ab
Doug Barton 44e687d0d7 Upgrade openssl to 0.9.6a and bump the shlib version in the process
due to non-backwards compatible changes. The shlib bump necessitates
a corresponding bump in bsd.port.mk for the automagic openssl
dependency. Mistakes in the port are my responsibility. Approval for
the bsd.port.mk commit comes through asami -> kkenn -> me. Kris is
a little busy at the moment, so he asked me to lob it in.

Approved by:	kris
2001-05-23 02:47:02 +00:00

34 lines
1.3 KiB
Plaintext

--- Makefile.org.orig Thu Apr 5 13:08:02 2001
+++ Makefile.org Mon Apr 23 01:08:26 2001
@@ -178,7 +178,7 @@
ONEDIRS=out tmp
EDIRS= times doc bugs util include certs ms shlib mt demos perl sf dep VMS
WDIRS= windows
-LIBS= libcrypto.a libssl.a
+LIBS= libcrypto.a libssl.a libRSAglue.a
SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
SHARED_SSL=libssl$(SHLIB_EXT)
SHARED_LIBS=
@@ -250,6 +250,21 @@
done
build-shared: clean-shared do_$(SHLIB_TARGET) link-shared
+
+freebsd-shared:
+ for i in ${SHLIBDIRS}; do \
+ rm -f lib$$i.a lib$$i.so \
+ lib$$i.so.${SHLIBVER}; \
+ ${MAKE} CC='${CC}' PLATFORM='${PLATFORM}' CFLAG='-fPIC ${CFLAG}' SDIRS='${SDIRS}' INSTALLTOP='${INSTALLTOP}' PEX_LIBS='${PEX_LIBS}' EX_LIBS='${EX_LIBS}' BN_ASM='${BN_ASM}' DES_ENC='${DES_ENC}' BF_ENC='${BF_ENC}' CAST_ENC='${CAST_ENC}' RC4_ENC='${RC4_ENC}' RC5_ENC='${RC5_ENC}' SHA1_ASM_OBJ='${SHA1_ASM_OBJ}' MD5_ASM_OBJ='${MD5_ASM_OBJ}' RMD160_ASM_OBJ='${RMD160_ASM_OBJ}' AR='${AR}' DIRS=$$i clean all || exit 1; \
+ ( set -x; ${CC} -nodefaultlibs -shared -o lib$$i.so.${SHLIBVER} \
+ -Wl,-S,-soname=lib$$i.so.${SHLIBVER} \
+ -Wl,${WHOLE_ARCHIVE_FLAG} lib$$i.a ) || exit 1; \
+ rm -f lib$$i.a; (cd $$i ; ${MAKE} clean) || exit 1 ;\
+ done;
+ @set -x; \
+ for i in ${SHLIBDIRS}; do \
+ ln -s lib$$i.so.${SHLIBVER} lib$$i.so; \
+ done;
do_bsd-gcc-shared: do_gnu-shared
do_linux-shared: do_gnu-shared