freebsd-ports/multimedia/mpegedit/files/patch-ba
Alexander Langer 0d731daf26 - Support CC/CXX/CFLAGS/CXXFLAGS/MAKE properly
- Support NOPORTDOCS
- Remove USE_GMAKE
- Add WWW: line into pkg/DESCR
- Add pnm.1 LIB_DEPENDS

PR:		19344
Submitted by:	KATO Tsuguru <tkato@prontomail.ne.jp>
2000-06-28 13:34:38 +00:00

43 lines
958 B
Plaintext

--- ui/Makefile.orig Mon Jul 24 00:01:36 1995
+++ ui/Makefile Thu Jun 15 09:04:16 2000
@@ -26,9 +26,10 @@
#
AR = ar r
-CPP = g++
+CPP = ${CXX}
RANLIB = ranlib
RM = rm -f
+INCLUDES = -I../globals -I$(X11BASE)/include
# CPPFLAGS -Wall all warnings
# -pipe speeds up compilation (remove only if not using g++)
@@ -48,7 +49,7 @@
.SUFFIXES: .C $(SUFFIXES)
.C.o:
- $(CPP) $(CPPFLAGS) $(EXTRA) -I../globals -c $<
+ $(CPP) $(CPPFLAGS) $(INCLUDES) $(EXTRA) -c $<
all: $(ALL)
@@ -65,14 +66,14 @@
dep: FORCE
$(RM) $(DEPFILE)
- make $(DEPFILE)
+ $(MAKE) $(DEPFILE)
$(DEPFILE):
- set -e; for i in $(SOURCES) ; do $(CPP) -M $$i -I../globals >>$(DEPFILE) ; done
-
+ set -e; for i in $(SOURCES) ; do $(CPP) $(INCLUDES) -M $$i >>$(DEPFILE) ; done
+
#
# include a dependency file if one exists
#
#ifeq ($(DEPFILE),$(wildcard $(DEPFILE)))
-include $(DEPFILE)
+#include $(DEPFILE)
#endif