freebsd-ports/lang/tclX/files/patch-ab
Mikhail Teterin 79fb1155cb I dreamed it would happen. I asked about. I finally did it
myself (for the lack of  children, whom I could've prohibited to
do it). Sorry.

Upgrade this port to:
	. build against TCL-8.3 by default (controllable by TCL_VER)
	. build with or without TK (controllable by NO_X)
	. take over maintainership -- regretfully, Justin was
	  rather idle recently
	. build the helpfiles once -- during the build stage --
	  not during the install stage

On a side  note, I more and  more resent the fact,  that our TCL
8.3 is built with the  -stubs. It just introduces more variables
without  noticeable benefit.  On FreeBSD  shared libraries  work
well...

I  tested this  with TCL-8.3  (with  and without  TK), and  with
TCL-8.2 (without TK only). Please, test this more.
2001-03-16 20:11:53 +00:00

62 lines
2.2 KiB
Plaintext

--- ../tcl/unix/Makefile.in.orig Sun Feb 6 18:53:59 2000
+++ ../tcl/unix/Makefile.in Thu Jul 13 15:35:23 2000
@@ -131,7 +131,7 @@
#
all: binaries libraries doc
-binaries: tcl checkup RUNTIME tclXtest
+binaries: tcl checkup RUNTIME
libraries: tcl.tndx tcl.tlib tclx.tcl buildidx.tcl
@@ -162,7 +162,8 @@
PATH=${TCL_UNIX_DIR}:${PATH}; export PATH; \
TCL_LIBRARY=${TCL_UNIX_DIR}/../library; export TCL_LIBRARY; \
LD_LIBRARY_PATH=${TCL_UNIX_DIR}:${LD_LIBRARY_PATH}; export LD_LIBRARY_PATH; \
- ${TCL_SHLIB_LD} -o ${TCLX_SHLIB_NAME} ${SOBJS} ${TCL_SHLIB_LD_LIBS}
+ ${TCL_SHLIB_LD} -o ${TCLX_SHLIB_NAME} ${SOBJS} @NEED_TCL_STUB@
+ ln -sf ${TCLX_SHLIB_NAME} `echo ${TCLX_SHLIB_NAME} | sed 's/\.so.*$$/.so/'`
hello: hello.c
${CC} ${LD_SWITCHES} -o $@ hello.c ${STATIC_LIBS}
@@ -184,7 +185,7 @@
# unless we don't have them.
#
RUNTIME: tcl.tlib tcl.tndx tclx.tcl buildidx.tcl autoload.tcl help.tmp \
- dltest.tmp checkup
+ checkup
tcl.tlib: ${TLIB_SRCS} autoload.tcl
-rm -f tcl.tlib tcl.tndx
@@ -306,7 +307,7 @@
buildhelp: tcl tcl.tndx
rm -rf ${HELP_DIR} help help.tmp
mkdir ${HELP_DIR}
- ${BLDMANHELP} ${TCL_SRC_DIR}/doc ${TCLX_TOOLS_SRC_DIR}/tclmanpages \
+ ${BLDMANHELP} ${TCLX_TOOLS_SRC_DIR}/tclmanpages \
${HELP_DIR} Tcl.brf
${RUNTCL} -c "buildhelp ${HELP_DIR} TclX.brf ${TCLX_DOC_DIR}/TclX.n"
@@ -322,3 +323,3 @@
-install-misc: buildhelp
+install-misc:
${INSTCOPY} ${TCLX_GENERIC_DIR}/tclExtend.h \
@@ -338,9 +339,11 @@
${INSTCOPY} ${TCLX_STLIB_NAME} ${INSTALL_ROOT}${TCLX_INST_LIB}; \
${RANLIB} ${INSTALL_ROOT}${TCLX_INST_LIB}/${TCLX_STLIB_NAME}; \
fi
- ${INSTCOPY} tclxConfig.sh ${INSTALL_ROOT}${TCLX_INST_LIB}
+ ${INSTCOPY} tclxConfig.sh ${INSTALL_ROOT}${TCLX_INST_RUNTIME}
if test "@SHARED_BUILD@" = "1"; then \
${INSTCOPY} ${TCLX_SHLIB_NAME} ${INSTALL_ROOT}${TCLX_INST_LIB} ;\
+ (cd ${INSTALL_ROOT}${TCLX_INST_LIB} && \
+ ln -sf ${TCLX_SHLIB_NAME} `echo ${TCLX_SHLIB_NAME} | sed 's/\.so.*$$/.so/'`) ;\
${INSTCOPY} pkgIndex.tcl ${INSTALL_ROOT}${TCLX_EXEC_RUNTIME} ;\
fi
@@ -385,2 +388,2 @@
tclXAppInit.o: ${TCLX_UNIX_SRC_DIR}/tclXAppInit.c
- ${CC} -c ${CC_SWITCHES} ${TCLX_UNIX_SRC_DIR}/tclXAppInit.c
+ ${CC} -c ${CC_SWITCHES} -UUSE_TCL_STUBS ${TCLX_UNIX_SRC_DIR}/tclXAppInit.c