freebsd-ports/net/ldap2dns/files/patch-Makefile
Martin Wilke 6b7299427a - Update to 0.4.1
PR:		ports/105038
Submitted by:	Gerrit Beine<gerrit.beine@gmx.de> (maintainer)
Sponsored by:   FreeBSD Bug-a-thon #2
2006-11-05 00:19:13 +00:00

28 lines
617 B
Plaintext

--- Makefile.orig Thu Oct 19 20:54:23 2006
+++ Makefile Sun Oct 29 16:56:03 2006
@@ -3,12 +3,12 @@
RELEASE=0
CC=gcc
DEBUG_CFLAGS=-g -ggdb
-CFLAGS=-O2
+CFLAGS=-O2 -I$(PREFIX)/include
LIBS=-lldap -llber
LD=gcc
-LDFLAGS=
-INSTALL_PREFIX=
-PREFIXDIR=$(INSTALL_PREFIX)/usr
+LDFLAGS= $(LIB)
+INSTALL_PREFIX=$(PREFIX)
+PREFIXDIR=$(INSTALL_PREFIX)
LDAPCONFDIR=$(INSTALL_PREFIX)/etc/openldap
SPECFILE=ldap2dns.spec
DISTRIBUTION=redhat
@@ -40,6 +40,7 @@
$(LD) $(LDFLAGS) $(LIBS) -o $@ $+
ldap2dns.o: ldap2dns.c
+ echo $(CFLAGS)
$(CC) $(CFLAGS) -DVERSION='"$(VERSION)"' -c $< -o $@
ldap2dns.o-dbg: ldap2dns.c