freebsd-ports/net/zebra-devel/files/patch-zebra_Makefile.in
Andreas Klemm 6e2dbdc869 upgrade to new zebra version 0.90
- removed PORTREVISION (new version)
- new configure script: dialog menue allows you to set different zebra
  compile time options (if ! BATCH), currently supported:
  --with-libpam         = enable PAM authentication for vtysh
  --enable-nssa         = enable OSPF NSSA
  --enable-snmp         = enable SNMP support
- please note: port compiles fine when all options are set, but
  functionality has not been tested by me.
- silence portlint, trim pkg-comment to <=70 columns
- remove unneeded patch patch, 0.90 now contains fix for memory leak
- cosmetic: add patch for Makefile.in (don't link with -g)
- portlint: o.k.

In this BETA --enable-unixdomain and --enable-newrib became default !
To get old implementation back use the following configure options:
--enable-tcp-zebra # TCP/IP socket is used for protocol daemon and zebra.
--enable-oldrib    # Turn on old RIB implementation.
Note: I didn't add these options to configure script, so that people
      don't choose the wrong thing !

Some milestones of this release (see file NEWS for complete list):
- access-lists can have remarks
- memory leak with access-list and prefix-list name fixed
- UNIX domain socket server of zebra protocol is added
- PointoPoint interface network bug fixed
- Metric value is reflected to kernel routing table
- New RIB implementation has been added:
- BGP passive peer support problem is fixed
- Redistributed IGP nexthop is passed to BGP nexthop
- Fix bug of holdtimer is not reset when bgp cleared
- BGP-MIB implementation is finished
- When BGP connection comes from unconfigured IP address, close socket
  immediately.
- BGP flap dampening feature is added
* RIP
- Fix bug of refreshing default route
* OSPF
- Fix bug of Hello packet's option is not properly set when interface comes up
- Reduce unconditional logging
- New command for virtual-link configuration
- Memory leak related classfull network generation is fixed
2001-01-11 21:45:05 +00:00

16 lines
600 B
Plaintext

--- zebra/Makefile.in.orig Thu Jan 11 11:22:36 2001
+++ zebra/Makefile.in Thu Jan 11 11:23:00 2001
@@ -331,10 +331,10 @@
zebra : $(zebra_OBJECTS) $(otherobj) ../lib/libzebra.a
- $(CC) -g -o zebra $(zebra_OBJECTS) $(otherobj) ../lib/libzebra.a $(LIBS) $(LIB_IPV6)
+ $(CC) -o zebra $(zebra_OBJECTS) $(otherobj) ../lib/libzebra.a $(LIBS) $(LIB_IPV6)
client : client_main.o ../lib/libzebra.a
- $(CC) -g -o client client_main.o ../lib/libzebra.a $(LIBS) $(LIB_IPV6)
+ $(CC) -o client client_main.o ../lib/libzebra.a $(LIBS) $(LIB_IPV6)
install-sysconfDATA: $(sysconf_DATA)
@$(NORMAL_INSTALL)