3e4ed01146
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
20 lines
441 B
Plaintext
20 lines
441 B
Plaintext
--- src/Makefile.orig Tue Oct 29 17:20:46 2002
|
|
+++ src/Makefile Wed Jul 23 21:35:39 2003
|
|
@@ -1,10 +1,14 @@
|
|
+CC= %%CC%%
|
|
+CFLAGS+= -g -I. -I%%LOCALBASE%%/include
|
|
+LIBS+= -L%%LOCALBASE%%/lib -lX11
|
|
+
|
|
all: 9box
|
|
|
|
9box: grab.o 9box.o manage.o menu.o buttons.o utils.o wm.o
|
|
- gcc -g -L/usr/X11R6/lib -lX11 -o $@ $^
|
|
+ $(CC) $(CFLAGS) $(LIBS) -o $@ $^
|
|
|
|
%.o: %.c
|
|
- gcc -g -c $< -o $@
|
|
+ $(CC) $(CFLAGS) -c $< -o $@
|
|
|
|
clean:
|
|
rm -f *.o 9box *~
|